blob: 200a0de8490a7e23afb682de8bf46816eb3672df [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "A simple memory benchmark program, which tries to measure the \
2peak bandwidth of sequential memory accesses and the latency of random memory \
3accesses. Bandwidth is measured by running different assembly code for the \
4aligned memory blocks and attempting different prefetch strategies"
5HOMEPAGE = "https://github.com/ssvb/tinymembench/wiki"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://main.c;endline=22;md5=879b9bbb60851454885b5fa47eb6b345"
8
Patrick Williams73bd93f2024-02-20 08:07:48 -06009PV = "0.4.9+git"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010
Brad Bishop19323692019-04-05 15:28:33 -040011SRCREV = "a2cf6d7e382e3aea1eb39173174d9fa28cad15f3"
Andrew Geissler595f6302022-01-24 19:11:47 +000012SRC_URI = "git://github.com/ssvb/tinymembench.git;branch=master;protocol=https \
Brad Bishop19323692019-04-05 15:28:33 -040013 file://0001-asm-Delete-.func-.endfunc-directives.patch \
14 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050015
16S = "${WORKDIR}/git"
17
Brad Bishop7f28bc52017-12-03 23:42:40 -050018TARGET_CC_ARCH += "${LDFLAGS}"
19
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020do_install() {
21 install -d ${D}${bindir}
22 install -m755 tinymembench ${D}${bindir}/
23}
24
25# Fails to build with thumb-1 (qemuarm)
26#| {standard input}: Assembler messages:
27#| {standard input}:66: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16'
28#| {standard input}:69: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16'
29#| {standard input}:82: Error: selected processor does not support Thumb mode `mla r3,r4,r3,r5'
30#| {standard input}:82: Error: unshifted register required -- `and r8,r7,r3,lsr#16'
31ARM_INSTRUCTION_SET = "arm"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032#
33# Does not work for 64bit mips.
34#
35COMPATIBLE_HOST = "^(?!mips64).*"