blob: d540737bc9e6da0b58a890a85dfcf9ee812e19c1 [file] [log] [blame]
Andrew Geissler32b11992021-03-31 13:37:05 -05001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A C library that may be linked into a C/C++ program to produce symbolic backtraces"
5HOMEPAGE = "https://github.com/ianlancetaylor/libbacktrace"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=24b5b3feec63c4be0975e1fea5100440"
8
9DEPENDS += "libunwind"
10
Andrew Geissler595f6302022-01-24 19:11:47 +000011SRC_URI = "git://github.com/ianlancetaylor/libbacktrace;protocol=https;branch=master"
Andrew Geissler32b11992021-03-31 13:37:05 -050012
Patrick Williams73bd93f2024-02-20 08:07:48 -060013PV = "1.0+git"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060014SRCREV = "9ae4f4ae4481b1e69d38ed810980d33103544613"
Andrew Geissler32b11992021-03-31 13:37:05 -050015
16S = "${WORKDIR}/git"
17
18inherit autotools
19
Patrick Williamsac13d5f2023-11-24 18:59:46 -060020EXTRA_OECONF += "--with-system-libunwind --enable-shared --disable-static"
Andrew Geissler32b11992021-03-31 13:37:05 -050021
22do_configure() {
23 oe_runconf
24}
25
Patrick Williamsf52e3dd2024-01-26 13:04:43 -060026RDEPENDS:${PN}-dev = ""
27
Patrick Williamsac13d5f2023-11-24 18:59:46 -060028# libunwind does not support RISCV32 yet
Patrick Williams213cb262021-08-07 19:21:33 -050029COMPATIBLE_HOST:riscv32 = "null"