blob: e8e275647c7b00956b473109d9551ba9f0fb70e1 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Makes working with XML feel like you are working with JSON"
Brad Bishope42b3e32020-01-15 22:08:42 -05002HOMEPAGE = "https://github.com/martinblech/xmltodict"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2"
5
Patrick Williams2194f502022-10-16 14:26:09 -05006SRC_URI[sha256sum] = "341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56"
Brad Bishope42b3e32020-01-15 22:08:42 -05007
8PYPI_PACKAGE = "xmltodict"
9
Andrew Geissler220dafd2023-10-04 10:18:08 -050010BBCLASSEXTEND = "native nativesdk"
11
Andrew Geissler82c905d2020-04-13 13:39:40 -050012inherit pypi setuptools3 ptest
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
Patrick Williams2194f502022-10-16 14:26:09 -050018RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-core \
20 python3-xml \
21 python3-io \
Patrick Williams2194f502022-10-16 14:26:09 -050022"
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060025 python3-pytest \
Andrew Geissler82c905d2020-04-13 13:39:40 -050026"
27
28do_install_ptest() {
29 install -d ${D}${PTEST_PATH}/tests
30 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
31}