blob: d69eb345e3c9fb3447c1a4166c4367e209be1551 [file] [log] [blame]
Patrick Williams2d10d8b2016-11-22 11:03:57 -06001inherit obmc-phosphor-utils
Matthew Barth04b910c2016-11-16 09:57:39 -06002inherit pythonnative
3
Patrick Williams9d46bd52016-11-22 13:27:02 -06004DEPENDS += "python"
5
Matthew Barth04b910c2016-11-16 09:57:39 -06006export BUILD_SYS
7export HOST_SYS
8export STAGING_INCDIR
9export STAGING_LIBDIR
10
Patrick Williams2d10d8b2016-11-22 11:03:57 -060011PYTHON_AUTOTOOLS_PACKAGE ?= "${PN}"
12
13python() {
14 for pkg in listvar_to_list(d, 'PYTHON_AUTOTOOLS_PACKAGE'):
15 set_append(d, 'FILES_%s' % pkg,
16 d.getVar('PYTHON_SITEPACKAGES_DIR', True))
17}