blob: 200ed0f709e56334760cdd99b8b8c146a26fe4e0 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Help browser for the GNOME desktop"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=6e1b9cb787e76d7e6946887a65caa754 \
5"
6
7inherit gnomebase itstool autotools-brokensep gsettings gettext gtk-doc features_check mime-xdg
8
9# for webkitgtk
10REQUIRED_DISTRO_FEATURES = "x11"
11
Patrick Williams975a06f2022-10-21 14:42:47 -050012SRC_URI[archive.sha256sum] = "a2c5fd0787a9089c722cc66bd0f85cdf7088d870e7b6cc85799f8e5bff9eac4b"
Andrew Geissler595f6302022-01-24 19:11:47 +000013
14DEPENDS += " \
15 libxml2-native \
16 glib-2.0-native \
17 gtk+3 \
18 appstream-glib \
19 libxslt \
20 sqlite3 \
Patrick Williamsde0582f2022-04-08 10:23:27 -050021 libhandy \
Andrew Geissler595f6302022-01-24 19:11:47 +000022 webkitgtk \
23 yelp-xsl \
24"
Patrick Williams7784c422022-11-17 07:29:11 -060025PACKAGECONFIG_SOUP ?= "soup3"
26PACKAGECONFIG ??= "${PACKAGECONFIG_SOUP}"
Andrew Geissler595f6302022-01-24 19:11:47 +000027
Patrick Williams7784c422022-11-17 07:29:11 -060028PACKAGECONFIG[soup2] = "--with-webkit2gtk-4-0,,"
Andrew Geissler595f6302022-01-24 19:11:47 +000029PACKAGECONFIG[soup3] = ",--with-webkit2gtk-4-0,"
30
Patrick Williams7784c422022-11-17 07:29:11 -060031
Andrew Geissler595f6302022-01-24 19:11:47 +000032do_configure:prepend() {
33 export ITSTOOL=${STAGING_BINDIR_NATIVE}/itstool
34}
35
36FILES:${PN} += " \
37 ${datadir}/metainfo \
38 ${datadir}/yelp-xsl \
39"
40
41RDEPENDS:${PN} += "yelp-xsl"