blob: 4537a09412d001d4e51dacb86a070564c0c8fb0f [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001# NOTE: mosh-server requires a UTF-8 locale, but there's no way to add
2# an explicit dependency for this so you need to ensure this is in your
3# image yourself when you install mosh-server.
4
5SUMMARY = "Remote shell supporting roaming and high-latency connections"
6DESCRIPTION = "Remote terminal application that allows roaming, supports \
7intermittent connectivity, and provides intelligent local echo and line \
8editing of user keystrokes. Mosh is a replacement for SSH. It's more \
9robust and responsive, especially over Wi-Fi, cellular, and \
10long-distance links."
11HOMEPAGE = "http://mosh.mit.edu"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012LICENSE = "GPL-3.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -040013LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
14
15DEPENDS = "protobuf-native protobuf ncurses zlib libio-pty-perl openssl libutempter"
16
Patrick Williams7784c422022-11-17 07:29:11 -060017SRC_URI = "http://mosh.mit.edu/mosh-${PV}.tar.gz"
18SRC_URI[sha256sum] = "872e4b134e5df29c8933dff12350785054d2fd2839b5ae6b5587b14db1465ddd"
Brad Bishop19323692019-04-05 15:28:33 -040019
20inherit autotools pkgconfig
21
22PACKAGE_BEFORE_PN += "${PN}-server"
Patrick Williams213cb262021-08-07 19:21:33 -050023FILES:${PN}-server = "${bindir}/mosh-server"
Brad Bishop19323692019-04-05 15:28:33 -040024
25NEEDED_PERL_MODULES = "\
26 perl-module-socket \
27 perl-module-getopt-long \
28 perl-module-errno \
29 perl-module-io-socket-inet \
30 perl-module-posix \
31"
32
33# mosh uses SSH to authenticate and the client uses OpenSSH-specific features
Patrick Williams213cb262021-08-07 19:21:33 -050034RDEPENDS:${PN} += "openssh-ssh ${NEEDED_PERL_MODULES}"
Brad Bishop19323692019-04-05 15:28:33 -040035# The server seemed not to work with dropbear either
Patrick Williams03907ee2022-05-01 06:28:52 -050036RDEPENDS:${PN}-server += "openssh-sshd"
Brad Bishop19323692019-04-05 15:28:33 -040037
38# Fails to build with thumb-1 (qemuarm)
39#| {standard input}: Assembler messages:
40#| {standard input}:2100: Error: instruction not supported in Thumb16 mode -- `adds r4,r4,r4'
41#| {standard input}:2101: Error: instruction not supported in Thumb16 mode -- `adcs r5,r5,r5'
42#| {standard input}:2102: Error: instruction not supported in Thumb16 mode -- `adcs r6,r6,r6'
43#| {standard input}:2103: Error: instruction not supported in Thumb16 mode -- `adcs r7,r7,r7'
44#| {standard input}:2104: Error: selected processor does not support Thumb mode `it cs'
45ARM_INSTRUCTION_SET = "arm"