blob: 6560bc3660d85e17b4335e001883dad8b7b0b59a [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Library for reading and editing the meta-data of popular audio formats"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Platform-independent library (tested on Windows/Linux) for reading and writing metadata in media files, including video, audio, and photo formats. This is a convenient one-stop-shop to present or tag all your media collection, regardless of which format/container these might use. You can read/write the standard or more common tags/properties of a media, or you can also create and retrieve your own custom tags."
Brad Bishop6e60e8b2018-02-01 10:27:11 -05003SECTION = "libs/multimedia"
4HOMEPAGE = "http://taglib.github.io/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-only | MPL-1.1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
7 file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
8 file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
9
10DEPENDS = "zlib"
11
Andrew Geissler95ac1b82021-03-31 14:34:31 -050012SRC_URI = "http://taglib.github.io/releases/${BP}.tar.gz"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
Patrick Williams7784c422022-11-17 07:29:11 -060014SRC_URI[sha256sum] = "58f08b4db3dc31ed152c04896ee9172d22052bc7ef12888028c01d8b1d60ade0"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
Andrew Geissler87f5cff2022-09-30 13:13:31 -050016UPSTREAM_CHECK_URI = "https://taglib.org/"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017
18BINCONFIG = "${bindir}/taglib-config"
19
20inherit cmake pkgconfig binconfig-disabled
21
22PACKAGES =+ "${PN}-c"
Patrick Williams213cb262021-08-07 19:21:33 -050023FILES:${PN}-c = "${libdir}/libtag_c.so.*"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024
25EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
26 -DCMAKE_DISABLE_FIND_PACKAGE_Boost=TRUE \
27 -DHAVE_BOOST_BYTESWAP=FALSE \
28 -DCMAKE_CXX_STANDARD=11 \
29 -DCMAKE_CXX_STANDARD_REQUIRED=OFF \
30 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
31"
32CXXFLAGS += "-std=c++11"
33
Patrick Williams213cb262021-08-07 19:21:33 -050034do_configure:prepend () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035 rm -f ${S}/admin/ltmain.sh
36 rm -f ${S}/admin/libtool.m4.in
37}
38
39# without -fPIC depending packages failed with many error like:
40# | <...>/ld: error: <...>/usr/lib/libtag.a(modfilebase.cpp.o): requires unsupported dynamic reloc R_ARM_THM_MOVW_ABS_NC; recompile with -fPIC
41CXXFLAGS += "-fPIC"