blob: 86f57d88ff50b24df84a69fdbda3c2aa3efa6337 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Lightweight http(s) proxy daemon"
2HOMEPAGE = "https://tinyproxy.github.io/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.gz \
Brad Bishope42b3e32020-01-15 22:08:42 -05007 file://disable-documentation.patch \
8 file://tinyproxy.service \
9 file://tinyproxy.conf \
10 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
Andrew Geissler78b72792022-06-14 06:47:25 -050012SRC_URI[sha256sum] = "1574acf7ba83c703a89e98bb2758a4ed9fda456f092624b33cfcf0ce2d3b2047"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
Andrew Geissler89770b02020-06-13 10:40:47 -050014UPSTREAM_CHECK_URI = "https://github.com/tinyproxy/tinyproxy/releases"
15
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016EXTRA_OECONF += " \
17 --enable-filter \
18 --enable-transparent \
19 --enable-reverse \
20 --enable-upstream \
21 --enable-xtinyproxy \
22 "
23
24inherit autotools systemd useradd
25
26#User specific
27USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050028USERADD_PARAM:${PN} = "--system --home /dev/null \
Brad Bishope42b3e32020-01-15 22:08:42 -050029 --no-user-group --gid nogroup tinyproxy"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030
31SYSTEMD_PACKAGES += "${BPN}"
Patrick Williams213cb262021-08-07 19:21:33 -050032SYSTEMD_SERVICE:${PN} = "tinyproxy.service"
33SYSTEMD_AUTO_ENABLE:${PN} = "enable"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034
Patrick Williams213cb262021-08-07 19:21:33 -050035do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
37 install -d ${D}${systemd_system_unitdir}
38 install -m 0644 ${WORKDIR}/tinyproxy.service ${D}${systemd_system_unitdir}
39 fi
Brad Bishope42b3e32020-01-15 22:08:42 -050040 install -m 0644 ${WORKDIR}/tinyproxy.conf ${D}${sysconfdir}/tinyproxy.conf
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041}