blob: 6fe0ec0fb35579ed1be597df24aa8934baac4957 [file] [log] [blame]
Patrick Venturec57ab162018-09-22 18:56:00 -07001SUMMARY = "Phosphor OEM IPMI Ethernet Stats Implementation"
2DESCRIPTION = "This package handles receiving OEM IPMI commands to provide ethernet device statistics."
3HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-ethstats"
Patrick Venturec57ab162018-09-22 18:56:00 -07004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Ed Tanous9936f862022-09-19 09:13:20 -07006DEPENDS += "autoconf-archive-native"
7DEPENDS += "phosphor-ipmi-host"
Andrew Geissler8ed5d4e2022-12-09 14:30:23 -06008SRCREV = "89dac6a829d8631f594f4b1f8faf05e389bad4e3"
Ed Tanous9936f862022-09-19 09:13:20 -07009PV = "0.1+git${SRCPV}"
10PR = "r1"
11
12SRC_URI = "git://github.com/openbmc/phosphor-ipmi-ethstats;branch=master;protocol=https"
13
14S = "${WORKDIR}/git"
Patrick Venturec57ab162018-09-22 18:56:00 -070015
16inherit autotools pkgconfig
17inherit obmc-phosphor-ipmiprovider-symlink
18
Ed Tanous9936f862022-09-19 09:13:20 -070019EXTRA_OECONF += "--disable-tests"
Patrick Venturec57ab162018-09-22 18:56:00 -070020
Patrick Williams12fc9392021-08-06 09:16:53 -050021FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
22FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
23FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
24FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venturec57ab162018-09-22 18:56:00 -070025
26HOSTIPMI_PROVIDER_LIBRARY += "libethstatscmd.so"