Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "XCB: The X protocol C binding library" |
| 2 | DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \ |
| 3 | for Xlib featuring a small footprint, latency hiding, direct access to \ |
| 4 | the protocol, improved threading support, and extensibility." |
| 5 | HOMEPAGE = "http://xcb.freedesktop.org" |
| 6 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB" |
| 7 | SECTION = "x11/libs" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7" |
| 11 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 12 | SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.xz \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | file://disable-check.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | " |
| 15 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "a55ed6db98d43469801262d81dc2572ed124edc3db31059d4e9916eb9f844c34" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | |
| 18 | BBCLASSEXTEND = "native nativesdk" |
| 19 | |
| 20 | DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp" |
| 21 | |
| 22 | PACKAGES_DYNAMIC = "^libxcb-.*" |
| 23 | |
| 24 | FILES_${PN} = "${libdir}/libxcb.so.*" |
| 25 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 26 | inherit autotools pkgconfig features_check |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | |
| 28 | # The libxau and others requires x11 in DISTRO_FEATURES |
| 29 | REQUIRED_DISTRO_FEATURES = "x11" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | |
| 31 | export PYTHON = "python3" |
| 32 | |
| 33 | python populate_packages_prepend () { |
| 34 | do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True) |
| 35 | } |