blob: 7d76ab76f0949a244b1d707ff57715a724a93eb7 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process."
2
3DESCRIPTION = "Plymouth is an application that runs very early in the boot process \
4 (even before the root filesystem is mounted!) that provides a \
5 graphical boot animation while the boot process happens in the background. \
6"
7
8HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth"
9SECTION = "base"
10
11LICENSE = "GPLv2+"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
14
15DEPENDS = "libcap libpng cairo dbus udev"
Patrick Williams213cb262021-08-07 19:21:33 -050016DEPENDS:append:libc-musl = " musl-rpmatch"
Brad Bishop19323692019-04-05 15:28:33 -040017PROVIDES = "virtual/psplash"
Patrick Williams213cb262021-08-07 19:21:33 -050018RPROVIDES:${PN} = "virtual-psplash virtual-psplash-support"
Brad Bishop19323692019-04-05 15:28:33 -040019
20SRC_URI = " \
21 http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.tar.xz \
22 file://0001-Make-full-path-to-systemd-tty-ask-password-agent-con.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023 file://0001-systemd-switch-to-KillMode-mixed.patch \
24 file://0001-plymouth-start-service-in-add-related-kernel-paramet.patch \
25 file://0001-plymouth-Add-the-retain-splash-option.patch \
Brad Bishop19323692019-04-05 15:28:33 -040026 "
27
Andrew Geisslerac970dd2021-02-12 15:32:45 -060028SRC_URI[md5sum] = "8a25d23f3ae732af300a56fa33cacff2"
Brad Bishop19323692019-04-05 15:28:33 -040029
30EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation \
31 --with-logo=${LOGO} \
Andrew Geisslereafcbb82020-06-05 17:59:17 -050032 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-systemd-tty-ask-password-agent=${base_bindir}/systemd-tty-ask-password-agent', '--disable-systemd-integration', d)} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050033 ${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge','--without-system-root-install','--with-system-root-install',d)} \
Brad Bishop19323692019-04-05 15:28:33 -040034"
35
36PACKAGECONFIG ??= "pango initrd"
Patrick Williams213cb262021-08-07 19:21:33 -050037PACKAGECONFIG:append:x86 = " drm"
38PACKAGECONFIG:append:x86-64 = " drm"
Brad Bishop19323692019-04-05 15:28:33 -040039
40PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
41PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
42PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
43PACKAGECONFIG[initrd] = ",,,"
44
45LOGO ??= "${datadir}/plymouth/bizcom.png"
46
Andrew Geisslerac970dd2021-02-12 15:32:45 -060047inherit autotools pkgconfig systemd gettext
Brad Bishop19323692019-04-05 15:28:33 -040048
Patrick Williams213cb262021-08-07 19:21:33 -050049LDFLAGS:append:libc-musl = " -lrpmatch"
Andrew Geissler32b11992021-03-31 13:37:05 -050050
Patrick Williams213cb262021-08-07 19:21:33 -050051do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040052 # Remove /var/run from package as plymouth will populate it on startup
53 rm -fr "${D}${localstatedir}/run"
54
55 if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
56 rm -rf "${D}${libexecdir}"
57 fi
58}
59
60PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}"
61PACKAGES =+ "${PN}-set-default-theme"
62
Patrick Williams213cb262021-08-07 19:21:33 -050063FILES:${PN}-initrd = "${libexecdir}/plymouth/*"
64FILES:${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme"
Brad Bishop19323692019-04-05 15:28:33 -040065
Patrick Williams213cb262021-08-07 19:21:33 -050066FILES:${PN} += "${systemd_unitdir}/system/*"
67FILES:${PN}-dbg += "${libdir}/plymouth/renderers/.debug"
Brad Bishop19323692019-04-05 15:28:33 -040068
69
Patrick Williams213cb262021-08-07 19:21:33 -050070RDEPENDS:${PN}-initrd = "bash dracut"
71RDEPENDS:${PN}-set-default-theme = "bash"
Brad Bishop19323692019-04-05 15:28:33 -040072
Patrick Williams213cb262021-08-07 19:21:33 -050073SYSTEMD_SERVICE:${PN} = "plymouth-start.service"