blob: 24271eb2bc32bb2f845aa0a6752c62de7a2746b2 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Set of CLI tools for Openlmi providers"
2DESCRIPTION = "openlmi-tools is a set of command line tools for Openlmi providers."
3HOMEPAGE = "http://www.openlmi.org/"
4LICENSE = "GPLv2+"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005LIC_FILES_CHKSUM = "file://../COPYING;md5=75859989545e37968a99b631ef42722e"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006SECTION = "System/Management"
7
Andrew Geissler82c905d2020-04-13 13:39:40 -05008inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "setuptools", "", d)}
Patrick Williamsb48b7b42016-08-17 15:04:38 -05009
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010SKIP_RECIPE[openlmi-tools] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
Andrew Geissler32b11992021-03-31 13:37:05 -050011
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012DEPENDS = "python-native python-pywbem-native python-m2crypto python-pywbem"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050013
14SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
15 "
16SRC_URI[md5sum] = "e156246cb7b49753db82f4ddf7f03e50"
17SRC_URI[sha256sum] = "292b8f5f2250655a4add8183c529b73358bc980bd4f23cfa484a940953fce9e4"
18
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019S = "${WORKDIR}/${BP}/cli"
20
Patrick Williams213cb262021-08-07 19:21:33 -050021do_configure:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 sed 's/@@VERSION@@/$(VERSION)/g' ${S}/setup.py.skel > ${S}/setup.py
Patrick Williamsb48b7b42016-08-17 15:04:38 -050023}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024
25python() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050026 if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
27 raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028}