blob: 43a9a6b7d32401f2a3691d36742b97801a76d31b [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Skip tests when modules not available"
2DESCRIPTION = "Skip test scripts if modules are not available. \
3The requested modules will be loaded, and optionally have their versions \
4checked. If the module is missing, the test script will be skipped. Modules \
5that are found but fail to compile will exit with an error rather than skip."
6
7HOMEPAGE = "https://metacpan.org/release/Test-Needs"
8SECTION = "libs"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010
11CPAN_NAME = "Test-Needs"
12CPAN_AUTHOR = "HAARG"
13
Brad Bishop393846f2019-05-20 12:24:11 -040014LIC_FILES_CHKSUM = "file://README;md5=3f3ccd21a0a48aa313db212cc3b1bc09;beginline=88;endline=89"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015
16DEPENDS += "perl"
17
Brad Bishop393846f2019-05-20 12:24:11 -040018SRC_URI = "https://cpan.metacpan.org/authors/id/H/HA/${CPAN_AUTHOR}/${CPAN_NAME}-${PV}.tar.gz"
Brad Bishop316dfdd2018-06-25 12:45:53 -040019
William A. Kennington IIIac69b482021-06-02 12:28:27 -070020SRC_URI[md5sum] = "5643cd323afb77d20363acbaf9b12bcc"
21SRC_URI[sha256sum] = "571c21193ad16195df58b06b268798796a391b398c443271721d2cc0fb7c4ac3"
Brad Bishop316dfdd2018-06-25 12:45:53 -040022
23S = "${WORKDIR}/${CPAN_NAME}-${PV}"
24
25inherit cpan ptest-perl
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:${PN}-ptest += "perl-module-test-more perl-module-ipc-open3 perl-module-lib perl-module-version"
Brad Bishop316dfdd2018-06-25 12:45:53 -040028
29BBCLASSEXTEND = "native"