blob: 71183ac7cecd883297914acd0c043b17480de2fe [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Subversion (svn) version control system client"
2HOMEPAGE = "http://subversion.apache.org"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "Subversion is an open source version control system."
Andrew Geissler82c905d2020-04-13 13:39:40 -05004SECTION = "console/network"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "Apache-2.0 & MIT"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=6487ae7094d359fa90fb9c4096e52e2b"
7
8DEPENDS = "apr-util serf sqlite3 file lz4"
Patrick Williams213cb262021-08-07 19:21:33 -05009DEPENDS:append:class-native = " file-replacement-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
11SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
12 file://disable_macos.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 file://serfmacro.patch \
14 "
15
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060016SRC_URI[sha256sum] = "2c5da93c255d2e5569fa91d92457fdb65396b0666fad4fd59b22e154d986e1a9"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
Andrew Geissler5a43b432020-06-13 10:46:56 -050018inherit autotools pkgconfig gettext python3native
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20CVE_PRODUCT = "apache:subversion"
21
22PACKAGECONFIG ?= ""
23
24PACKAGECONFIG[boost] = "--with-boost=${RECIPE_SYSROOT}${exec_prefix},--without-boost,boost"
25PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl"
26PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring,--without-gnome-keyring,glib-2.0 gnome-keyring"
27
28EXTRA_OECONF = " \
29 --with-apr=${STAGING_BINDIR_CROSS} \
30 --with-apr-util=${STAGING_BINDIR_CROSS} \
31 --without-apxs \
32 --without-berkeley-db \
33 --without-swig \
34 --disable-keychain \
35 --with-utf8proc=internal \
36 ac_cv_path_RUBY=none \
37"
38
39EXTRA_OEMAKE += "pkgconfig_dir=${libdir}/pkgconfig"
40
41acpaths = "-I build/ -I build/ac-macros/"
42
43CPPFLAGS += "-P"
44BUILD_CPPFLAGS += "-P"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046do_configure:prepend () {
Andrew Geissler82c905d2020-04-13 13:39:40 -050047 rm -f ${S}/libtool
48 rm -f ${S}/build/libtool.m4 ${S}/build/ltmain.sh ${S}/build/ltoptions.m4 ${S}/build/ltsugar.m4 ${S}/build/ltversion.m4 ${S}/build/lt~obsolete.m4
49 rm -f ${S}/aclocal.m4
50 sed -i -e 's:with_sasl="/usr/local":with_sasl="${STAGING_DIR}":' ${S}/build/ac-macros/sasl.m4
51}
52
53#| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_local/libsvn_ra_local-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| /usr/bin/ld: cannot find -lsvn_delta-1| collect2: ld returned 1 exit status| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_svn/libsvn_ra_svn-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_serf/libsvn_ra_serf-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
54#| x86_64-linux-libtool: install: error: relink `libsvn_ra_serf-1.la' with the above command before installing it
55#| x86_64-linux-libtool: install: warning: `../../subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
56#| /home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/subversion-1.8.9/build-outputs.mk:1090: recipe for target 'install-serf-lib' failed
57#| make: *** [install-serf-lib] Error 1
58PARALLEL_MAKEINST = ""
59
Patrick Williams213cb262021-08-07 19:21:33 -050060RDEPENDS:${PN} = "serf"
Andrew Geissler82c905d2020-04-13 13:39:40 -050061
Andrew Geisslerb7d28612020-07-24 16:15:54 -050062BBCLASSEXTEND = "native nativesdk"