blob: e72a114de98f00cb9b6ed9693de8a5a031bfe10b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU cpio is a program to manage archives of files"
2DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \
3another. It handles a number of cpio formats as well as reading and writing tar files."
4HOMEPAGE = "http://www.gnu.org/software/cpio/"
5SECTION = "base"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-3.0-only"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
8
9SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
10 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -050011 file://0002-src-global.c-Remove-superfluous-declaration-of-progr.patch \
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050012 file://CVE-2021-38185.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 "
14
15SRC_URI[md5sum] = "389c5452d667c23b5eceb206f5000810"
16SRC_URI[sha256sum] = "e87470d9c984317f658567c03bfefb6b0c829ff17dbf6b0de48d71a4c8f3db88"
17
18inherit autotools gettext texinfo
19
William A. Kennington IIIac69b482021-06-02 12:28:27 -070020# Issue applies to use of cpio in SUSE/OBS, doesn't apply to us
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000021CVE_CHECK_IGNORE += "CVE-2010-4226"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070022
Andrew Geissler82c905d2020-04-13 13:39:40 -050023EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
24
25do_install () {
26 autotools_do_install
27 if [ "${base_bindir}" != "${bindir}" ]; then
28 install -d ${D}${base_bindir}/
29 mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio"
Andrew Geissler475cb722020-07-10 16:00:51 -050030 if [ "${sbindir}" != "${bindir}" ]; then
31 rmdir ${D}${bindir}/
32 fi
Andrew Geissler82c905d2020-04-13 13:39:40 -050033 fi
34
35 # Avoid conflicts with the version from tar
36 mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8"
37}
38
39PACKAGES =+ "${PN}-rmt"
40
Patrick Williams213cb262021-08-07 19:21:33 -050041FILES:${PN}-rmt = "${sbindir}/rmt*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050042
43inherit update-alternatives
44
45ALTERNATIVE_PRIORITY = "100"
46
Patrick Williams213cb262021-08-07 19:21:33 -050047ALTERNATIVE:${PN} = "cpio"
48ALTERNATIVE:${PN}-rmt = "rmt"
Andrew Geissler82c905d2020-04-13 13:39:40 -050049
50ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
51
52ALTERNATIVE_PRIORITY[rmt] = "50"
53ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
54
Andrew Geissler475cb722020-07-10 16:00:51 -050055BBCLASSEXTEND = "native nativesdk"