blob: 564599fdf6a517d8cc99ff137139244e587fb98f [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "GNU Midnight Commander is a visual file manager, licensed under GNU General Public License and therefore qualifies as Free Software. It's a feature rich full-screen text mode application that allows you to copy, move and delete files and whole directory trees, search for files and run commands in the subshell. Internal viewer and editor are included."
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LICENSE = "GPL-3.0-only"
Brad Bishop19323692019-04-05 15:28:33 -04005LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
6SECTION = "console/utils"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -05007DEPENDS = "ncurses glib-2.0 util-linux file-replacement-native"
Patrick Williams213cb262021-08-07 19:21:33 -05008RDEPENDS:${PN} = "ncurses-terminfo-base"
9RRECOMMENDS:${PN} = "ncurses-terminfo"
Brad Bishop19323692019-04-05 15:28:33 -040010
11SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
12 file://0001-mc-replace-perl-w-with-use-warnings.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 file://nomandate.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000014 file://0001-Ticket-4200-fix-FTBFS-with-ncurses-build-with-disabl.patch \
Brad Bishop19323692019-04-05 15:28:33 -040015 "
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050016SRC_URI[sha256sum] = "2f52dd9c75c20d8eac7701bd3a8c6c125aaf8cdd9cf12b78ca50a0102b543407"
17
18# remove at next version upgrade or when output changes
19PR = "r1"
20HASHEQUIV_HASH_VERSION .= ".2"
Brad Bishop19323692019-04-05 15:28:33 -040021
22inherit autotools gettext pkgconfig
23
24#
25# Both Samba (smb) and sftp require package delivered from meta-openembedded
26#
27PACKAGECONFIG ??= ""
28PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba,"
29PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
30
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000031# enable NCURSES_WIDECHAR=1 only if ENABLE_WIDEC has not been explicitly disabled (e.g. by the distro config).
32# When compiling against the ncurses library, NCURSES_WIDECHAR needs to explicitly set to 0 in this case.
33CFLAGS:append:libc-musl = "${@' -DNCURSES_WIDECHAR=1' if bb.utils.to_boolean((d.getVar('ENABLE_WIDEC') or 'True')) else ' -DNCURSES_WIDECHAR=0'}"
Brad Bishop1d80a2e2019-11-15 16:35:03 -050034EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-configure-args"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050035EXTRANATIVEPATH += "file-native"
Brad Bishop19323692019-04-05 15:28:33 -040036
37CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
Brad Bishop1d80a2e2019-11-15 16:35:03 -050038CACHED_CONFIGUREVARS += "ac_cv_path_PYTHON='/usr/bin/env python'"
39CACHED_CONFIGUREVARS += "ac_cv_path_GREP='/usr/bin/env grep'"
Andrew Geissler82c905d2020-04-13 13:39:40 -050040CACHED_CONFIGUREVARS += "mc_cv_have_zipinfo=yes"
Brad Bishop19323692019-04-05 15:28:33 -040041
Patrick Williams213cb262021-08-07 19:21:33 -050042do_install:append () {
Brad Bishop19323692019-04-05 15:28:33 -040043 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
44
45 rm ${D}${libexecdir}/mc/extfs.d/s3+ ${D}${libexecdir}/mc/extfs.d/uc1541
46}
47
48PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish"
49
Patrick Williams213cb262021-08-07 19:21:33 -050050SUMMARY:${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
51FILES:${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
Brad Bishop19323692019-04-05 15:28:33 -040052 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
53 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
54 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
55 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
56 ${libexecdir}/mc/extfs.d/uzip"
Patrick Williams213cb262021-08-07 19:21:33 -050057RDEPENDS:${BPN}-helpers-perl = "perl"
Brad Bishop19323692019-04-05 15:28:33 -040058
Patrick Williams213cb262021-08-07 19:21:33 -050059SUMMARY:${BPN}-helpers = "Midnight Commander shell helper scripts"
60FILES:${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
Brad Bishop19323692019-04-05 15:28:33 -040061
Patrick Williams213cb262021-08-07 19:21:33 -050062SUMMARY:${BPN}-fish = "Midnight Commander Fish scripts"
63FILES:${BPN}-fish = "${libexecdir}/mc/fish"