blob: 1a16ed437471083c731688bb1e0e78d2f523ea09 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Custom Matchbox session files"
Brad Bishop1d80a2e2019-11-15 16:35:03 -05002DESCRIPTION = "Very simple session manager for matchbox tools"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003HOMEPAGE = "http://www.matchbox-project.org/"
4BUGTRACKER = "http://bugzilla.yoctoproject.org/"
5
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-2.0-only"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007LIC_FILES_CHKSUM = "file://matchbox-session;endline=20;md5=180f1c169a15d059a56c30094f6fb5ea"
8
9SECTION = "x11"
Patrick Williams213cb262021-08-07 19:21:33 -050010RCONFLICTS:${PN} = "matchbox-common"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12SRC_URI = "file://matchbox-session"
13S = "${WORKDIR}"
14
15PR = "r4"
16
17inherit update-alternatives
18
Patrick Williams213cb262021-08-07 19:21:33 -050019ALTERNATIVE:${PN} = "x-session-manager"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/matchbox-session"
21ALTERNATIVE_PRIORITY = "100"
22
23do_install() {
24 install -d ${D}/${bindir}
25 install -m 0755 ${S}/matchbox-session ${D}/${bindir}
26}