blob: c888f3d7e18bb6d9cb48669d8ea9ce16f3aba626 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "GNOME XSLT library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "libxslt is the XSLT C parser and toolkit developed for the Gnome project. \
3XSLT itself is a an XML language to define transformation for XML. Libxslt is based on \
4libxml2 the XML C library developed for the GNOME project. It also implements most of \
5the EXSLT set of processor-portable extensions functions and some of Saxon's evaluate \
6and expressions extensions."
Brad Bishop19323692019-04-05 15:28:33 -04007HOMEPAGE = "http://xmlsoft.org/XSLT/"
8BUGTRACKER = "https://bugzilla.gnome.org/"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
12
13SECTION = "libs"
14DEPENDS = "libxml2"
15
Brad Bishopf3fd2882019-06-21 08:06:37 -040016SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz \
Brad Bishop6dbb3162019-11-25 09:41:34 -050017 "
Brad Bishop19323692019-04-05 15:28:33 -040018
Brad Bishop6dbb3162019-11-25 09:41:34 -050019SRC_URI[md5sum] = "db8765c8d076f1b6caafd9f2542a304a"
20SRC_URI[sha256sum] = "98b1bd46d6792925ad2dfe9a87452ea2adebf69dcb9919ffd55bf926a7f93f7f"
Brad Bishop19323692019-04-05 15:28:33 -040021
22UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
23
24S = "${WORKDIR}/libxslt-${PV}"
25
26BINCONFIG = "${bindir}/xslt-config"
27
Andrew Geissler82c905d2020-04-13 13:39:40 -050028inherit autotools pkgconfig binconfig-disabled lib_package multilib_header
Brad Bishop19323692019-04-05 15:28:33 -040029
Patrick Williams213cb262021-08-07 19:21:33 -050030do_configure:prepend () {
Brad Bishop15ae2502019-06-18 21:44:24 -040031 # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header.
32 # This can be removed when upgrading to 1.1.34.
Brad Bishop19323692019-04-05 15:28:33 -040033 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
34
35 # The timestamps in the 1.1.28 tarball are messed up causing this file to
36 # appear out of date. Touch it so that we don't try to regenerate it.
37 touch ${S}/doc/xsltproc.1
38}
39
40EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}"
41# older versions of this recipe had ${PN}-utils
Patrick Williams213cb262021-08-07 19:21:33 -050042RPROVIDES:${PN}-bin += "${PN}-utils"
43RCONFLICTS:${PN}-bin += "${PN}-utils"
44RREPLACES:${PN}-bin += "${PN}-utils"
Brad Bishop19323692019-04-05 15:28:33 -040045
46# This is only needed until libxml can load the relocated catalog itself
Patrick Williams213cb262021-08-07 19:21:33 -050047do_install:append:class-native () {
Brad Bishop19323692019-04-05 15:28:33 -040048 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
49}
50
Patrick Williams213cb262021-08-07 19:21:33 -050051do_install:append () {
Andrew Geissler82c905d2020-04-13 13:39:40 -050052 oe_multilib_header libxslt/xsltconfig.h
53}
54
Patrick Williams213cb262021-08-07 19:21:33 -050055FILES:${PN} += "${libdir}/libxslt-plugins"
56FILES:${PN}-dev += "${libdir}/xsltConf.sh"
Brad Bishop19323692019-04-05 15:28:33 -040057
58BBCLASSEXTEND = "native nativesdk"