blob: e04cf51c984fb855ee5b08cec3cd87ac2d4b78c0 [file] [log] [blame]
Brad Bishopb1e88402017-01-11 11:12:32 -05001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
Patrick Venturebc174e62018-10-01 20:22:40 -07004PV = "1.0+git${SRCPV}"
Brad Bishopb1e88402017-01-11 11:12:32 -05005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Patrick Venturebc174e62018-10-01 20:22:40 -07008inherit autotools pkgconfig
9inherit obmc-phosphor-systemd
Brad Bishop4186efb2017-01-11 15:30:07 -050010
Brad Bishop4ce57192017-08-01 21:33:30 -040011PACKAGE_BEFORE_PN = "max31785-msl"
12SYSTEMD_PACKAGES = "${PN} max31785-msl"
13
Brad Bishop4186efb2017-01-11 15:30:07 -050014SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
Brad Bishop4ce57192017-08-01 21:33:30 -040015SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service"
Brad Bishopb1e88402017-01-11 11:12:32 -050016
17DEPENDS += "autoconf-archive-native"
Brad Bishop6d105112017-02-20 14:36:31 -050018DEPENDS += " \
19 sdbusplus \
William A. Kennington III4e10c562018-10-18 19:23:49 -070020 sdeventplus \
Patrick Venture6e2600f2020-05-21 08:32:30 -070021 stdplus \
Brad Bishop6d105112017-02-20 14:36:31 -050022 phosphor-dbus-interfaces \
23 phosphor-logging \
Patrick Venturef67ce692018-09-14 09:54:18 -070024 gpioplus \
Patrick Venture806405f2019-03-11 14:06:11 -070025 cli11 \
Brad Bishop6d105112017-02-20 14:36:31 -050026 "
27
Brad Bishopb1e88402017-01-11 11:12:32 -050028
29RDEPENDS_${PN} += "\
Joel Stanley1c7e17d2017-09-05 17:44:33 +100030 bash \
Brad Bishopb1e88402017-01-11 11:12:32 -050031 "
32
Brad Bishop3217b272017-02-22 20:50:13 -050033RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
34
Brad Bishop4ce57192017-08-01 21:33:30 -040035FILES_max31785-msl = "${bindir}/max31785-msl"
36RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools"
37
Brad Bishopb1e88402017-01-11 11:12:32 -050038SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
Brad Bishop4186efb2017-01-11 15:30:07 -050039SRC_URI += "file://70-hwmon.rules"
Brandon Wyman7cae3ea2017-06-21 16:32:56 -050040SRC_URI += "file://70-iio.rules"
Joel Stanley1c7e17d2017-09-05 17:44:33 +100041SRC_URI += "file://start_hwmon.sh"
Brad Bishopb1e88402017-01-11 11:12:32 -050042
Andrew Geissler813c7ed2020-07-24 16:11:34 +000043SRCREV = "7ab1b25b50bd4f68062c6a07200f8f69f09d3387"
Brad Bishopb1e88402017-01-11 11:12:32 -050044
45S = "${WORKDIR}/git"
Brad Bishop4186efb2017-01-11 15:30:07 -050046
47do_install_append() {
48
Brad Bishop2b9921e2017-01-26 09:12:57 -050049 install -d ${D}/${base_libdir}/udev/rules.d/
Brad Bishopb09e0092019-11-14 14:37:51 -050050 install -m 0644 ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
51 install -m 0644 ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/
Joel Stanley1c7e17d2017-09-05 17:44:33 +100052
53 install -d ${D}${bindir}
54 install -m 0755 ${WORKDIR}/start_hwmon.sh ${D}${bindir}
Brad Bishop4186efb2017-01-11 15:30:07 -050055}