blob: 14718184bd6e8a178394b6cc4ee2825bde9d21fe [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A graphical front-end for gcov"
2HOMEPAGE = "http://ltp.sourceforge.net/coverage/lcov.php"
3DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \
4tool gcov. It collects gcov data for multiple source files and creates \
5HTML pages containing the source code annotated with coverage information. \
6It also adds overview pages for easy navigation within the file structure. \
Patrick Williamsddad1a12017-02-23 20:36:32 -06007LCOV supports statement, function and branch coverage measurement."
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008LICENSE = "GPL-2.0"
9LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
10
11RDEPENDS_${PN} += " \
12 gcov \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 gcov-symlinks \
14 libjson-perl \
15 libperlio-gzip-perl \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016 perl \
17 perl-module-filehandle \
18 perl-module-getopt-std \
Brad Bishop0e2770c2020-01-21 07:31:46 -050019 perl-module-digest-md5 \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020 perl-module-digest-sha \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021 perl-module-constant \
22 perl-module-cwd \
23 perl-module-errno \
24 perl-module-file-basename \
Andrew Geissler82c905d2020-04-13 13:39:40 -050025 perl-module-file-copy \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026 perl-module-file-find \
27 perl-module-file-path \
28 perl-module-file-spec \
29 perl-module-file-spec-functions \
30 perl-module-file-spec-unix \
31 perl-module-file-temp \
32 perl-module-getopt-long \
33 perl-module-list-util \
34 perl-module-mro \
35 perl-module-overload \
36 perl-module-overloading \
37 perl-module-overload-numbers \
38 perl-module-parent \
39 perl-module-pod-usage \
40 perl-module-posix \
41 perl-module-re \
42 perl-module-safe \
43 perl-module-scalar-util \
44 perl-module-term-cap \
45 perl-module-text-parsewords \
46 perl-module-tie-hash \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050047"
48
Andrew Geissler82c905d2020-04-13 13:39:40 -050049SRC_URI = " \
50 http://downloads.sourceforge.net/ltp/${BP}.tar.gz \
51 file://0001-geninfo-Add-intermediate-text-format-support.patch \
52 file://0002-geninfo-Add-intermediate-JSON-format-support.patch \
53 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050054
Brad Bishop15ae2502019-06-18 21:44:24 -040055SRC_URI[md5sum] = "0220d01753469f83921f8f41ae5054c1"
56SRC_URI[sha256sum] = "14995699187440e0ae4da57fe3a64adc0a3c5cf14feab971f8db38fb7d8f071a"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050057
58do_install() {
Brad Bishop15ae2502019-06-18 21:44:24 -040059 oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir}
Patrick Williamsb48b7b42016-08-17 15:04:38 -050060}
61
Andrew Geissler82c905d2020-04-13 13:39:40 -050062BBCLASSEXTEND = "native nativesdk"