blob: 2fc07669dd4d0c5871e4084b634c3f20e0a14583 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Helper utilities needed by the runqemu script"
2LICENSE = "GPLv2"
Brad Bishop19323692019-04-05 15:28:33 -04003RDEPENDS_${PN} = "qemu-system-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004PR = "r1"
5
6LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999"
7
Andrew Geissler82c905d2020-04-13 13:39:40 -05008SRC_URI = "\
9 file://tunctl.c \
10 file://qemu-oe-bridge-helper \
11 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012
13S = "${WORKDIR}"
14
15inherit native
16
17do_compile() {
Brad Bishop64c979e2019-11-04 13:55:29 -050018 ${CC} ${CFLAGS} ${LDFLAGS} -Wall tunctl.c -o tunctl
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019}
20
21do_install() {
22 install -d ${D}${bindir}
23 install tunctl ${D}${bindir}/
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25 install -m 755 ${WORKDIR}/qemu-oe-bridge-helper ${D}${bindir}/
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027
Brad Bishop19323692019-04-05 15:28:33 -040028DEPENDS += "qemu-system-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029addtask addto_recipe_sysroot after do_populate_sysroot before do_build