blob: 4e217a351dd484731c1c8d27606bec91f05cd7fc [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
2HOMEPAGE = "http://www.chronox.de/libkcapi.html"
3LICENSE = "BSD | GPL-2.0"
Brad Bishop19323692019-04-05 15:28:33 -04004LIC_FILES_CHKSUM = "file://COPYING;md5=14d5a68b28755c04ebdba226e888b157"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005
6DEPENDS = "libtool"
7
8S = "${WORKDIR}/git"
Brad Bishop26bdd442019-08-16 17:08:17 -04009SRCREV = "5649050d201856bf06c8738b5d2aa1710c86ac2f"
10PV = "1.1.5"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011SRC_URI = " \
12 git://github.com/smuellerDD/libkcapi.git \
Brad Bishop23eaf032019-11-20 05:15:02 -050013 file://0001-kcapi-kdf-Move-code-to-fix.patch \
Brad Bishop8410d612019-11-25 09:40:59 -050014 file://0001-Use-__builtin_bswap32-on-Clang-if-supported.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015"
16
17inherit autotools
18
19PACKAGECONFIG ??= ""
Brad Bishop19323692019-04-05 15:28:33 -040020PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
22
23do_install_append() {
24 # bindir contains testapp and apps. However it is always created, even
25 # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
26 rmdir --ignore-fail-on-non-empty ${D}${bindir}
Brad Bishop19323692019-04-05 15:28:33 -040027
28 # Remove the generated binary checksum files
29 rm -f ${D}${bindir}/.*.hmac
30 rm -f ${D}${libdir}/.*.hmac
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031}
32
33CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare"