Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "GStreamer examples (including gtk-play, gst-play)" |
| 2 | LICENSE = "LGPL-2.0+" |
| 3 | LIC_FILES_CHKSUM = "file://playback/player/gtk/gtk-play.c;beginline=1;endline=20;md5=f8c72dae3d36823ec716a9ebcae593b9" |
| 4 | |
| 5 | DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gtk+3 glib-2.0-native" |
| 6 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | SRC_URI = "git://gitlab.freedesktop.org/gstreamer/gst-examples.git;protocol=https \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 8 | file://0001-Make-player-examples-installable.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 9 | file://gst-player.desktop \ |
| 10 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 12 | SRCREV = "d953c127c1146b50d5676618299933950685dcd7" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 16 | inherit meson pkgconfig features_check |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | |
| 18 | |
| 19 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
| 20 | |
| 21 | do_install_append() { |
| 22 | install -m 0644 -D ${WORKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop |
| 23 | } |
| 24 | |
| 25 | RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback" |
| 26 | RRECOMMENDS_${PN} = "gstreamer1.0-plugins-base-meta \ |
| 27 | gstreamer1.0-plugins-good-meta \ |
| 28 | gstreamer1.0-plugins-bad-meta \ |
| 29 | ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-libav", "", d)} \ |
| 30 | ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}" |
| 31 | RPROVIDES_${PN} += "gst-player gst-player-bin" |