blob: b5bcc633395370b9ceacdecb5e32bd3df2e1ca31 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "pam-ssh-agent-auth"
2DESCRIPTION = "A PAM module which permits authentication via ssh-agent."
3HOMEPAGE = "http://sourceforge.net/projects/pamsshagentauth/"
4SECTION = "libs"
Patrick Williams03907ee2022-05-01 06:28:52 -05005LICENSE = "OpenSSL & BSD-2-Clause & BSD-3-Clause"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006LIC_FILES_CHKSUM = "file://LICENSE.OpenSSL;md5=8ab01146141ded59b75f8ba7811ed05a \
7 file://OPENSSH_LICENSE;md5=7ae09218173be1643c998a4b71027f9b \
8"
9
Brad Bishop19323692019-04-05 15:28:33 -040010SRC_URI = "http://sourceforge.net/projects/pamsshagentauth/files/pam_ssh_agent_auth/v${PV}/pam_ssh_agent_auth-${PV}.tar.bz2 \
11 file://0001-Adapt-to-OpenSSL-1.1.1.patch \
12 file://0002-Check-against-the-correct-OPENSSL_VERSION_NUMBER.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013 file://0001-configure-Include-stdio.h-for-printf.patch \
Brad Bishop19323692019-04-05 15:28:33 -040014 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015SRC_URI[md5sum] = "8dbe90ab3625e545036333e6f51ccf1d"
16SRC_URI[sha256sum] = "3c53d358d6eaed1b211239df017c27c6f9970995d14102ae67bae16d4f47a763"
17
Brad Bishop19323692019-04-05 15:28:33 -040018DEPENDS += "libpam openssl"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
Brad Bishop8410d612019-11-25 09:40:59 -050020inherit features_check
Brad Bishop316dfdd2018-06-25 12:45:53 -040021REQUIRED_DISTRO_FEATURES = "pam"
22
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023# This gets us ssh-agent, which we are almost certain to want.
24#
Patrick Williams213cb262021-08-07 19:21:33 -050025RDEPENDS:${PN} += "openssh-misc"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026
27# Kind of unfortunate to have underscores in the name.
28#
29S = "${WORKDIR}/pam_ssh_agent_auth-${PV}"
30
Andrew Geissler82c905d2020-04-13 13:39:40 -050031inherit autotools-brokensep perlnative
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032
33# Avoid autoreconf. Override the --libexec oe_runconf specifies so that
34# the module is put with the other pam modules. Because it cannot, in general,
35# do a runtime test, configure wants to use rpl_malloc() and rpl_realloc()
36# instead of malloc() and realloc(). We set variables to tell it not to because
37# these functions do not exist.
38#
39do_configure () {
40 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
41 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
42 oe_runconf --without-openssl-header-check --libexecdir=${base_libdir}/security \
43 ac_cv_func_malloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes
44}
45
46# Link with CC. Configure cannot figure out the correct AR.
47#
48do_compile () {
49 oe_runmake LD="${CC}" AR="${AR}"
50}
51
52# This stuff is not any place looked at by default.
53#
Patrick Williams213cb262021-08-07 19:21:33 -050054FILES:${PN} += "${base_libdir}/security/pam*"
55FILES:${PN}-dbg += "${base_libdir}/security/.debug"