blob: a35b54e3bc145e47ed8c4642844be2c1b2f44699 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "DJB daemontools"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://cr.yp.to/daemontools.html"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05003DESCRIPTION = "supervise monitors a service. It starts the service and restarts the \
4service if it dies. The companion svc program stops, pauses, or restarts \
5the service on sysadmin request. The svstat program prints a one-line \
6status report. \
7multilog saves error messages to one or more logs. It optionally timestamps \
8each line and, for each log, includes or excludes lines matching specified \
9patterns. It automatically rotates logs to limit the amount of disk space \
10used. If the disk fills up, it pauses and tries again, without losing any \
11data."
12
13SECTION = "System/Servers"
14
Brad Bishop0f291cc2019-09-01 15:16:57 -040015LIC_FILES_CHKSUM = "file://src/prot.c;beginline=1;endline=1;md5=96964cadf07e8f8c1e2ffb3b507dd647"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016LICENSE = "PD"
17
Andrew Geissler87f5cff2022-09-30 13:13:31 -050018DEPENDS += "coreutils"
19
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020SRC_URI = "http://cr.yp.to/daemontools/${BPN}-${PV}.tar.gz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050021 file://0001-error.h-include-errno.h-instead-of-extern-int.diff \
22 file://0002-supervise.c-.-supervise-may-be-a-symlink-if-it-s-da.diff \
23 file://cross-compile.patch \
24 file://0001-daemontools-Fix-QA-Issue.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050025 file://warnings.patch \
26 file://0001-Fix-signature-of-main-function.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050028
29SRC_URI[md5sum] = "1871af2453d6e464034968a0fbcb2bfc"
30SRC_URI[sha256sum] = "a55535012b2be7a52dcd9eccabb9a198b13be50d0384143bd3b32b8710df4c1f"
31
Andrew Geissler82c905d2020-04-13 13:39:40 -050032S = "${WORKDIR}/admin/${BP}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050033
34do_compile() {
35 ./package/compile
36}
37
38do_install() {
39 install -d ${D}/${bindir}
40}
41
Patrick Williams213cb262021-08-07 19:21:33 -050042do_install:append:class-target() {
Patrick Williamsb48b7b42016-08-17 15:04:38 -050043 install -m755 ${S}/command/* ${D}/${bindir}
44}
45
Andrew Geissler82c905d2020-04-13 13:39:40 -050046inherit update-alternatives
47ALTERNATIVE_PRIORITY = "100"
Patrick Williams213cb262021-08-07 19:21:33 -050048ALTERNATIVE:${PN} = "svc svok"