blob: a2ed8d71bc1a4802a4b24bbdc4a7c46c4f1d7c4d [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/libxml2"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
8 file://hash.c;beginline=6;endline=15;md5=e77f77b12cb69e203d8b4090a0eee879 \
9 file://list.c;beginline=4;endline=13;md5=b9c25b021ccaf287e50060602d20f3a7 \
10 file://trio.c;beginline=5;endline=14;md5=cd4f61e27f88c1d43df112966b1cd28f"
11
12DEPENDS = "zlib virtual/libiconv"
13
14inherit gnomebase
15
16SRC_URI += "http://www.w3.org/XML/Test/xmlts20080827.tar.gz;subdir=${BP};name=testtar \
17 file://libxml-64bit.patch \
18 file://runtest.patch \
19 file://run-ptest \
20 file://python-sitepackages-dir.patch \
21 file://0001-Make-ptest-run-the-python-tests-if-python-is-enabled.patch \
22 file://fix-execution-of-ptests.patch \
23 file://remove-fuzz-from-ptests.patch \
24 file://libxml-m4-use-pkgconfig.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050025 file://0001-Port-gentest.py-to-Python-3.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000026 "
Andrew Geissler9aee5002022-03-30 16:27:02 +000027
Andrew Geisslerd5838332022-05-27 11:33:10 -050028SRC_URI[archive.sha256sum] = "60d74a257d1ccec0475e749cba2f21559e48139efba6ff28224357c7c798dfee"
Andrew Geissler9aee5002022-03-30 16:27:02 +000029SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
30
31BINCONFIG = "${bindir}/xml2-config"
32
Patrick Williams92b42cb2022-09-03 06:53:57 -050033# Fixed since 2.9.11 via
34# https://gitlab.gnome.org/GNOME/libxml2/-/commit/c1ba6f54d32b707ca6d91cb3257ce9de82876b6f
35CVE_CHECK_IGNORE += "CVE-2016-3709"
36
Andrew Geissler9aee5002022-03-30 16:27:02 +000037PACKAGECONFIG ??= "python \
38 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
39"
40PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python3"
41PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
42
43inherit autotools pkgconfig binconfig-disabled ptest
44
45inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3targetconfig', '', d)}
46
47RDEPENDS:${PN}-ptest += "bash make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
48
49RDEPENDS:${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
50
51RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-gconv-ebcdic-us \
52 glibc-gconv-ibm1141 \
53 glibc-gconv-iso8859-5 \
54 glibc-gconv-euc-jp \
55 locale-base-en-us \
56 "
57
58export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
59
60# WARNING: zlib is required for RPM use
61EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
62EXTRA_OECONF:class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
63EXTRA_OECONF:class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
64EXTRA_OECONF:linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
65
66python populate_packages:prepend () {
67 # autonamer would call this libxml2-2, but we don't want that
68 if d.getVar('DEBIAN_NAMES'):
69 d.setVar('PKG:libxml2', '${MLPREFIX}libxml2')
70}
71
72PACKAGE_BEFORE_PN += "${PN}-utils"
73PACKAGES += "${PN}-python"
74
75FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
76FILES:${PN}-dev += "${libdir}/xml2Conf.sh"
77FILES:${PN}-utils = "${bindir}/*"
78FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
79
80do_configure:prepend () {
81 # executables take longer to package: these should not be executable
82 find ${S}/xmlconf/ -type f -exec chmod -x {} \+
83}
84
85do_compile_ptest() {
Andrew Geissler87f5cff2022-09-30 13:13:31 -050086 # Make sure that testapi.c is newer than gentests.py, because
87 # with reproducible builds, they will both get e.g. Jan 1 1970
88 # modification time from SOURCE_DATE_EPOCH and then check-am
89 # might try to rebuild_testapi, which will fail even with
90 # 0001-Port-gentest.py-to-Python-3.patch, because it needs
91 # libxml2 module (libxml2-native dependency and correctly
92 # set PYTHON_SITE_PACKAGES), it's easier to
93 # just rely on pre-generated testapi.c from the release
94 touch ${S}/testapi.c
95
Andrew Geissler9aee5002022-03-30 16:27:02 +000096 oe_runmake check-am
97}
98
99do_install_ptest () {
100 cp -r ${S}/xmlconf ${D}${PTEST_PATH}
101 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
102 sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
103 ${D}${PTEST_PATH}/python/tests/Makefile
104 grep -lrZ '#!/usr/bin/python' ${D}${PTEST_PATH}/python |
105 xargs -0 sed -i -e 's|/usr/bin/python|${USRBINPATH}/${PYTHON_PN}|'
106 fi
107 #Remove build host references from various Makefiles
108 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
109 sed -i \
110 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
111 -e 's|${DEBUG_PREFIX_MAP}||g' \
112 -e 's:${HOSTTOOLS_DIR}/::g' \
113 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
114 -e 's:${RECIPE_SYSROOT}::g' \
115 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
116 -e '/^RELDATE/d' \
117 {} +
118}
119
120do_install:append:class-native () {
121 # Docs are not needed in the native case
122 rm ${D}${datadir}/gtk-doc -rf
Patrick Williams92b42cb2022-09-03 06:53:57 -0500123
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500124 create_wrapper ${D}${bindir}/xmllint 'XML_CATALOG_FILES=${XML_CATALOG_FILES:-${sysconfdir}/xml/catalog}'
Andrew Geissler9aee5002022-03-30 16:27:02 +0000125}
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500126do_install[vardepsexclude] += "XML_CATALOG_FILES:-${sysconfdir}/xml/catalog"
Andrew Geissler9aee5002022-03-30 16:27:02 +0000127
128BBCLASSEXTEND = "native nativesdk"