blob: 13f7c8305f8d3384aee9382a870f637225e4244b [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "There are two major versions of the PCRE library. The \
2newest version is PCRE2, which is a re-working of the original PCRE \
3library to provide an entirely new API. The original, very widely \
4deployed PCRE library's API and feature are stable, future releases \
5 will be for bugfixes only. All new future features will be to PCRE2, \
6not the original PCRE 8.x series."
7SUMMARY = "Perl Compatible Regular Expressions version 2"
8HOMEPAGE = "http://www.pcre.org"
9SECTION = "devel"
10LICENSE = "BSD-3-Clause"
Patrick Williams03907ee2022-05-01 06:28:52 -050011LIC_FILES_CHKSUM = "file://LICENCE;md5=41bfb977e4933c506588724ce69bf5d2"
Andrew Geissler595f6302022-01-24 19:11:47 +000012
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRC_URI = "${GITHUB_BASE_URI}/download/pcre2-${PV}/pcre2-${PV}.tar.bz2"
Andrew Geissler595f6302022-01-24 19:11:47 +000014
Andrew Geissler87f5cff2022-09-30 13:13:31 -050015GITHUB_BASE_URI = "https://github.com/PhilipHazel/pcre2/releases"
16UPSTREAM_CHECK_REGEX = "releases/tag/pcre2-(?P<pver>.+)"
Andrew Geissler595f6302022-01-24 19:11:47 +000017
Patrick Williams03907ee2022-05-01 06:28:52 -050018SRC_URI[sha256sum] = "14e4b83c4783933dc17e964318e6324f7cae1bc75d8f3c79bc6969f00c159d68"
Andrew Geissler595f6302022-01-24 19:11:47 +000019
20CVE_PRODUCT = "pcre2"
21
22S = "${WORKDIR}/pcre2-${PV}"
23
24PROVIDES += "pcre2"
25DEPENDS += "bzip2 zlib"
26
27BINCONFIG = "${bindir}/pcre2-config"
28
Andrew Geissler87f5cff2022-09-30 13:13:31 -050029inherit autotools binconfig-disabled github-releases
Andrew Geissler595f6302022-01-24 19:11:47 +000030
31EXTRA_OECONF = "\
32 --enable-newline-is-lf \
33 --with-link-size=2 \
34 --with-match-limit=10000000 \
35 --enable-pcre2-16 \
36 --enable-pcre2-32 \
37"
38CFLAGS += "-D_REENTRANT"
39CXXFLAGS:append:powerpc = " -lstdc++"
40
41PACKAGES =+ "libpcre2-16 libpcre2-32 pcre2grep pcre2grep-doc pcre2test pcre2test-doc"
42
43SUMMARY:pcre2grep = "grep utility that uses perl 5 compatible regexes"
44SUMMARY:pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs"
45SUMMARY:pcre2test = "program for testing Perl-comatible regular expressions"
46SUMMARY:pcre2test-doc = "program for testing Perl-comatible regular expressions - docs"
47
48FILES:libpcre2-16 = "${libdir}/libpcre2-16.so.*"
49FILES:libpcre2-32 = "${libdir}/libpcre2-32.so.*"
50FILES:pcre2grep = "${bindir}/pcre2grep"
51FILES:pcre2grep-doc = "${mandir}/man1/pcre2grep.1"
52FILES:pcre2test = "${bindir}/pcre2test"
53FILES:pcre2test-doc = "${mandir}/man1/pcre2test.1"
54
55BBCLASSEXTEND = "native nativesdk"