blob: 7371faf0178f802df386a990b643a7f0060f6fa6 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Userspace library to access USB (version 1.0)"
2DESCRIPTION = "A cross-platform library to access USB devices from Linux, \
3macOS, Windows, OpenBSD/NetBSD, Haiku and Solaris userspace."
4HOMEPAGE = "https://libusb.info"
5BUGTRACKER = "http://www.libusb.org/report"
6SECTION = "libs"
7
8LICENSE = "LGPL-2.1-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
10
11BBCLASSEXTEND = "native nativesdk"
12
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/libusb-${PV}.tar.bz2 \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000014 file://run-ptest \
15 "
16
Andrew Geissler87f5cff2022-09-30 13:13:31 -050017GITHUB_BASE_URI = "https://github.com/libusb/libusb/releases"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000018
Patrick Williams03907ee2022-05-01 06:28:52 -050019SRC_URI[sha256sum] = "12ce7a61fc9854d1d2a1ffe095f7b5fac19ddba095c259e6067a46500381b5a5"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000020
21S = "${WORKDIR}/libusb-${PV}"
22
Andrew Geissler87f5cff2022-09-30 13:13:31 -050023inherit autotools pkgconfig ptest github-releases
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024
25PACKAGECONFIG:class-target ??= "udev"
26PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev"
27
28EXTRA_OECONF = "--libdir=${base_libdir}"
29
30do_install:append() {
31 install -d ${D}${libdir}
32 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
33 mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
34 fi
35}
36
37do_compile_ptest() {
38 oe_runmake -C tests stress
39}
40
41do_install_ptest() {
42 install -m 755 ${B}/tests/.libs/stress ${D}${PTEST_PATH}
43}
44
45FILES:${PN} += "${base_libdir}/*.so.*"
46
47FILES:${PN}-dev += "${base_libdir}/*.so ${base_libdir}/*.la"