blob: c1839b37a8e555cee580bcc61abdc65a5f1a1a8f [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "haveged - A simple entropy daemon"
2DESCRIPTION = "The haveged project is an attempt to provide an easy-to-use, unpredictable random number generator based upon an adaptation of the HAVEGE algorithm. Haveged was created to remedy low-entropy conditions in the Linux random device that can occur under some workloads, especially on headless servers."
3AUTHOR = "Gary Wuertz"
4HOMEPAGE = "http://www.issihosts.com/haveged/index.html"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM="file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
Andrew Geissler89770b02020-06-13 10:40:47 -05008# v1.9.9
9SRCREV = "6da706c8026b629d9bb7ebebc32239305a03da8e"
Brad Bishop19323692019-04-05 15:28:33 -040010SRC_URI = "git://github.com/jirka-h/haveged.git \
Brad Bishop19323692019-04-05 15:28:33 -040011"
12S = "${WORKDIR}/git"
13
14UPSTREAM_CHECK_URI = "https://github.com/jirka-h/haveged/releases"
15
16inherit autotools update-rc.d systemd
17
18EXTRA_OECONF = "\
19 --enable-nistest=yes \
20 --enable-olt=yes \
21 --enable-threads=no \
22"
23
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
Brad Bishop8410d612019-11-25 09:40:59 -050025PACKAGECONFIG[systemd] = "--enable-init=service.fedora --enable-initdir=${systemd_system_unitdir}, --enable-init=sysv.redhat, systemd"
Brad Bishop19323692019-04-05 15:28:33 -040026
27INITSCRIPT_PACKAGES = "${PN}"
28INITSCRIPT_NAME = "haveged"
29INITSCRIPT_PARAMS_${PN} = "defaults 9"
30
31SYSTEMD_PACKAGES = "${PN}"
32SYSTEMD_SERVICE_${PN} = "haveged.service"
33
34do_install_append() {
35 # The exit status is 143 when the service is stopped
36 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
37 sed -i '/ExecStart/a SuccessExitStatus=143' ${D}${systemd_system_unitdir}/haveged.service
Brad Bishop2f973922019-11-11 07:58:48 -050038 # Hybrid systemd-sysvinit distros must install the initscript manually
39 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
40 install -d ${D}${INIT_D_DIR}
41 sed -e "s,@SBINDIR@,${sbindir},g" <${S}/init.d/sysv.redhat >${D}${INIT_D_DIR}/haveged
42 chmod 755 ${D}${INIT_D_DIR}/haveged
43 fi
Brad Bishop19323692019-04-05 15:28:33 -040044 fi
45}
46
47MIPS_INSTRUCTION_SET = "mips"