blob: 469914cd4791373cdb4c71641126257c5e68841c [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process."
Brad Bishop19323692019-04-05 15:28:33 -04002DESCRIPTION = "Plymouth is an application that runs very early in the boot process \
Patrick Williams8dd68482022-10-04 07:57:18 -05003(even before the root filesystem is mounted!) that provides a \
4graphical boot animation while the boot process happens in the background."
Brad Bishop19323692019-04-05 15:28:33 -04005HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth"
6SECTION = "base"
7
Andrew Geissler9aee5002022-03-30 16:27:02 +00008LICENSE = "GPL-2.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -04009LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
10
Brad Bishop19323692019-04-05 15:28:33 -040011SRC_URI = " \
12 http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.tar.xz \
13 file://0001-Make-full-path-to-systemd-tty-ask-password-agent-con.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000014 file://0001-plymouth-start-service-in-add-related-kernel-paramet.patch \
15 file://0001-plymouth-Add-the-retain-splash-option.patch \
Patrick Williams8dd68482022-10-04 07:57:18 -050016 file://0001-Use-standard-runstatedir-vs-custom-flag.patch \
17 file://0001-Fix-daemon-install-ignoring-configured-runstatedir.patch \
Brad Bishop19323692019-04-05 15:28:33 -040018"
19
Patrick Williams8dd68482022-10-04 07:57:18 -050020SRC_URI[sha256sum] = "100551442221033ce868c447ad6c74d831d209c18ae232b98ae0207e34eadaeb"
21
22LOGO ??= "${datadir}/plymouth/bizcom.png"
23RUNSTATEDIR ??= "${localstatedir}/run"
24
25EXTRA_OECONF = "--runstatedir=${RUNSTATEDIR}"
26
27PACKAGECONFIG ??= "initrd logo pango udev ${@bb.utils.filter('DISTRO_FEATURES', 'systemd usrmerge', d)}"
Patrick Williams213cb262021-08-07 19:21:33 -050028PACKAGECONFIG:append:x86 = " drm"
29PACKAGECONFIG:append:x86-64 = " drm"
Brad Bishop19323692019-04-05 15:28:33 -040030
31PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
Patrick Williams8dd68482022-10-04 07:57:18 -050032PACKAGECONFIG[documentation] = "--enable-documentation,--disable-documentation"
33PACKAGECONFIG[initrd] = ",,"
Brad Bishop19323692019-04-05 15:28:33 -040034PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
Patrick Williams8dd68482022-10-04 07:57:18 -050035PACKAGECONFIG[logo] = "--with-logo=${LOGO},--without-logo"
36PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
37PACKAGECONFIG[systemd] = "--enable-systemd-integration --with-systemd-tty-ask-password-agent=${base_bindir}/systemd-tty-ask-password-agent,--disable-systemd-integration,systemd"
38PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev"
39PACKAGECONFIG[upstart-monitoring] = "--enable-upstart-monitoring,--disable-upstart-monitoring,ncurses dbus"
40PACKAGECONFIG[usrmerge] = "--without-system-root-install,--with-system-root-install"
Brad Bishop19323692019-04-05 15:28:33 -040041
Andrew Geisslerac970dd2021-02-12 15:32:45 -060042inherit autotools pkgconfig systemd gettext
Brad Bishop19323692019-04-05 15:28:33 -040043
Patrick Williams213cb262021-08-07 19:21:33 -050044do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040045 # Remove /var/run from package as plymouth will populate it on startup
Patrick Williams8dd68482022-10-04 07:57:18 -050046 rm -fr ${D}${RUNSTATEDIR}
Brad Bishop19323692019-04-05 15:28:33 -040047
48 if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
49 rm -rf "${D}${libexecdir}"
50 fi
51}
52
Patrick Williams8dd68482022-10-04 07:57:18 -050053PROVIDES = "virtual/psplash"
54RPROVIDES:${PN} = "virtual-psplash virtual-psplash-support"
55
Brad Bishop19323692019-04-05 15:28:33 -040056PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}"
57PACKAGES =+ "${PN}-set-default-theme"
58
Patrick Williams213cb262021-08-07 19:21:33 -050059FILES:${PN}-initrd = "${libexecdir}/plymouth/*"
60FILES:${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme"
Brad Bishop19323692019-04-05 15:28:33 -040061
Patrick Williams213cb262021-08-07 19:21:33 -050062FILES:${PN} += "${systemd_unitdir}/system/*"
63FILES:${PN}-dbg += "${libdir}/plymouth/renderers/.debug"
Brad Bishop19323692019-04-05 15:28:33 -040064
Patrick Williams8dd68482022-10-04 07:57:18 -050065DEPENDS = "libcap libpng"
66DEPENDS:append:libc-musl = " musl-rpmatch"
67
68LDFLAGS:append:libc-musl = " -lrpmatch"
Brad Bishop19323692019-04-05 15:28:33 -040069
Patrick Williams213cb262021-08-07 19:21:33 -050070RDEPENDS:${PN}-initrd = "bash dracut"
71RDEPENDS:${PN}-set-default-theme = "bash"
Brad Bishop19323692019-04-05 15:28:33 -040072
Patrick Williams213cb262021-08-07 19:21:33 -050073SYSTEMD_SERVICE:${PN} = "plymouth-start.service"