blob: 20021177465c575b29e0d1dcc873a609cadacddc [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Opus Audio Codec"
2DESCRIPTION = "The Opus codec is designed for interactive \
3speech and audio transmission over the Internet. It is \
4designed by the IETF Codec Working Group and incorporates \
5technology from Skype's SILK codec and Xiph.Org's CELT codec."
6HOMEPAGE = "http://www.opus-codec.org/"
7SECTION = "libs/multimedia"
Brad Bishop2d39a062019-10-28 08:33:36 -04008LICENSE = "BSD-3-Clause"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=e304cdf74c2a1b0a33a5084c128a23a3"
10
11SRC_URI = "http://downloads.xiph.org/releases/opus/opus-${PV}.tar.gz"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050012SRC_URI[sha256sum] = "c9b32b4253be5ae63d1ff16eea06b94b5f0f2951b7a02aceef58e3a3ce49c51f"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
14S = "${WORKDIR}/opus-${PV}"
15
16inherit autotools pkgconfig
17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG[fixed-point] = "--enable-fixed-point,,"
20PACKAGECONFIG[float-approx] = "--enable-float-approx,,"
21
22EXTRA_OECONF = " \
23 --with-NE10-includes=${STAGING_DIR_TARGET}${includedir} \
24 --with-NE10-libraries=${STAGING_DIR_TARGET}${libdir} \
25 --enable-asm \
26 --enable-intrinsics \
27 --enable-custom-modes \
28"
29
Brad Bishop15ae2502019-06-18 21:44:24 -040030# ne10 is available only for armv7a, armv7ve and aarch64
Patrick Williams213cb262021-08-07 19:21:33 -050031DEPENDS:append:aarch64 = " ne10"
32DEPENDS:append:armv7a = " ne10"
33DEPENDS:append:armv7ve = " ne10"
Brad Bishopc342db32019-05-15 21:57:59 -040034
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035python () {
36 if d.getVar('TARGET_FPU') in [ 'soft' ]:
37 d.appendVar('PACKAGECONFIG', ' fixed-point')
Brad Bishop6e60e8b2018-02-01 10:27:11 -050038}
39
40# Fails to build with thumb-1 (qemuarm)
41#| {standard input}: Assembler messages:
42#| {standard input}:389: Error: selected processor does not support Thumb mode `smull r5,r7,r1,r4'
43#| {standard input}:418: Error: selected processor does not support Thumb mode `smull r5,r6,r4,r1'
44#| {standard input}:448: Error: selected processor does not support Thumb mode `smull r4,r5,r1,r0'
45#| {standard input}:474: Error: selected processor does not support Thumb mode `smull r0,r4,r8,r1'
46#| {standard input}:510: Error: selected processor does not support Thumb mode `smull fp,r0,r10,r1'
47#| {standard input}:553: Error: selected processor does not support Thumb mode `smull fp,r1,r10,r3'
48#| {standard input}:741: Error: selected processor does not support Thumb mode `smull r3,r0,r6,r10'
49#| {standard input}:761: Error: selected processor does not support Thumb mode `smull fp,r2,r3,r9'
50#| {standard input}:773: Error: selected processor does not support Thumb mode `smull fp,r3,r5,r8'
51#| make[2]: *** [celt/celt.lo] Error 1
Patrick Williams213cb262021-08-07 19:21:33 -050052ARM_INSTRUCTION_SET:armv5 = "arm"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080053
54BBCLASSEXTEND = "native nativesdk"