blob: 6095ae1cdf103b940fa9345b856f5c96fa089597 [file] [log] [blame]
Andrew Geisslerf1e44062021-04-15 15:52:46 -05001SUMMARY = "Parsec Command Line Interface"
2HOMEPAGE = "https://github.com/parallaxsecond/parsec-tool"
3LICENSE = "Apache-2.0"
Patrick Williams8e7b46e2023-05-01 14:19:06 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
Andrew Geisslerf1e44062021-04-15 15:52:46 -05005
Patrick Williams8e7b46e2023-05-01 14:19:06 -05006inherit cargo cargo-update-recipe-crates
Andrew Geisslerf1e44062021-04-15 15:52:46 -05007
8SRC_URI += "crate://crates.io/parsec-tool/${PV} \
9"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050010SRC_URI[parsec-tool-0.6.0.sha256sum] = "f51d5d7f0caca1c335324b52482fa5edbf6c9cfd2e6865e5cb22716d52dcb367"
Andrew Geisslerf1e44062021-04-15 15:52:46 -050011
Patrick Williams8e7b46e2023-05-01 14:19:06 -050012S = "${CARGO_VENDORING_DIRECTORY}/${BP}"
Patrick Williams93c203f2021-10-06 16:15:23 -050013
Andrew Geisslerf1e44062021-04-15 15:52:46 -050014do_install() {
15 install -d ${D}/${bindir}
Patrick Williams92b42cb2022-09-03 06:53:57 -050016 install -m 755 "${B}/target/${CARGO_TARGET_SUBDIR}/parsec-tool" "${D}${bindir}/parsec-tool"
Patrick Williams93c203f2021-10-06 16:15:23 -050017 install -m 755 "${S}/tests/parsec-cli-tests.sh" "${D}${bindir}/parsec-cli-tests.sh"
Andrew Geisslerf1e44062021-04-15 15:52:46 -050018}
19
Patrick Williams8e7b46e2023-05-01 14:19:06 -050020require parsec-tool-crates.inc
Patrick Williams2390b1b2022-11-03 13:47:49 -050021
Patrick Williams8e7b46e2023-05-01 14:19:06 -050022RDEPENDS:${PN} = "openssl-bin"
23
24# The QA check has been temporarily disabled. An issue has been created
25# upstream to fix this.
Patrick Williams2390b1b2022-11-03 13:47:49 -050026# https://github.com/parallaxsecond/parsec-tool/issues/94
27INSANE_SKIP:${PN}-dbg += "buildpaths"