blob: 6ffac4fadedaf6d1ae84f25a13c86d259d91b345 [file] [log] [blame]
Patrick Williams03907ee2022-05-01 06:28:52 -05001# Copyright (C) 2022 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3#
4SUMMARY = "Locales support for musl"
Andrew Geisslerd5838332022-05-27 11:33:10 -05005HOMEPAGE = "https://git.adelielinux.org/adelie/musl-locales/-/wikis/home"
Patrick Williams03907ee2022-05-01 06:28:52 -05006LICENSE = "MIT & LGPL-3.0-or-later"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=cf5713fba707073020b1db2acaa73e78 \
8 file://LICENSE.MIT;md5=a4f1c6864a83ddf4b754cdab7d593523"
9
Andrew Geisslerd5838332022-05-27 11:33:10 -050010SRC_URI = "git://git.adelielinux.org/adelie/musl-locales;protocol=https;branch=main"
Patrick Williams03907ee2022-05-01 06:28:52 -050011
12PV = "1.0+git${SRCPV}"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050013SRCREV = "5663f5bfd30bf9e1e0ba3fc5fe2da6725969f30e"
Patrick Williams03907ee2022-05-01 06:28:52 -050014
15S = "${WORKDIR}/git"
16
17DEPENDS = "virtual/libintl gettext-native"
18
19PROVIDES = "virtual/libc-locale"
20
21inherit cmake
22
23# We will skip parsing for non-musl systems
24python () {
25 if d.getVar('TCLIBC') != "musl":
26 raise bb.parse.SkipRecipe("Only use it with Musl C library")
27}
28
29# only locale binaries are under GPL-3.0-or-later others are MIT
30LICENSE:${PN} = "LGPL-3.0-or-later"
Andrew Geisslerd5838332022-05-27 11:33:10 -050031LICENSE:locale-base-cs-cz = "MIT"
Patrick Williams03907ee2022-05-01 06:28:52 -050032LICENSE:locale-base-de-ch = "MIT"
33LICENSE:locale-base-de-de = "MIT"
34LICENSE:locale-base-en-gb = "MIT"
35LICENSE:locale-base-en-us = "MIT"
36LICENSE:locale-base-es-es = "MIT"
Andrew Geisslerd5838332022-05-27 11:33:10 -050037LICENSE:locale-base-fi-fi = "MIT"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050038LICENSE:locale-base-fr-ca = "MIT"
Patrick Williams03907ee2022-05-01 06:28:52 -050039LICENSE:locale-base-fr-fr = "MIT"
40LICENSE:locale-base-it-it = "MIT"
41LICENSE:locale-base-nb-no = "MIT"
42LICENSE:locale-base-nl-nl = "MIT"
43LICENSE:locale-base-pt-br = "MIT"
Andrew Geisslerd5838332022-05-27 11:33:10 -050044LICENSE:locale-base-pt-pt = "MIT"
Patrick Williams03907ee2022-05-01 06:28:52 -050045LICENSE:locale-base-ru-ru = "MIT"
Andrew Geisslerd5838332022-05-27 11:33:10 -050046LICENSE:locale-base-sr-rs = "MIT"
Patrick Williams03907ee2022-05-01 06:28:52 -050047LICENSE:locale-base-sv-se = "MIT"
48
Andrew Geisslerd5838332022-05-27 11:33:10 -050049PACKAGES =+ "locale-base-cs-cz \
Patrick Williams03907ee2022-05-01 06:28:52 -050050 locale-base-de-ch \
51 locale-base-de-de \
52 locale-base-en-gb \
53 locale-base-en-us \
54 locale-base-es-es \
Andrew Geisslerd5838332022-05-27 11:33:10 -050055 locale-base-fi-fi \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050056 locale-base-fr-ca \
Patrick Williams03907ee2022-05-01 06:28:52 -050057 locale-base-fr-fr \
58 locale-base-it-it \
59 locale-base-nb-no \
60 locale-base-nl-nl \
61 locale-base-pt-br \
Andrew Geisslerd5838332022-05-27 11:33:10 -050062 locale-base-pt-pt \
Patrick Williams03907ee2022-05-01 06:28:52 -050063 locale-base-ru-ru \
Andrew Geisslerd5838332022-05-27 11:33:10 -050064 locale-base-sr-rs \
Patrick Williams03907ee2022-05-01 06:28:52 -050065 locale-base-sv-se \
66 "
Andrew Geisslerd5838332022-05-27 11:33:10 -050067FILES:locale-base-cs-cz += "${datadir}/i18n/locales/musl/cs_CZ.UTF-8"
Patrick Williams03907ee2022-05-01 06:28:52 -050068FILES:locale-base-de-ch += "${datadir}/i18n/locales/musl/de_CH.UTF-8"
69FILES:locale-base-de-de += "${datadir}/i18n/locales/musl/de_DE.UTF-8"
70FILES:locale-base-en-gb += "${datadir}/i18n/locales/musl/en_GB.UTF-8"
71FILES:locale-base-en-us += "${datadir}/i18n/locales/musl/en_US.UTF-8"
72FILES:locale-base-es-es += "${datadir}/i18n/locales/musl/es_ES.UTF-8"
Andrew Geisslerd5838332022-05-27 11:33:10 -050073FILES:locale-base-fi-fi += "${datadir}/i18n/locales/musl/fi_FI.UTF-8"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050074FILES:locale-base-fr-ca += "${datadir}/i18n/locales/musl/fr_CA.UTF-8"
Patrick Williams03907ee2022-05-01 06:28:52 -050075FILES:locale-base-fr-fr += "${datadir}/i18n/locales/musl/fr_FR.UTF-8"
76FILES:locale-base-it-it += "${datadir}/i18n/locales/musl/it_IT.UTF-8"
77FILES:locale-base-nb-no += "${datadir}/i18n/locales/musl/nb_NO.UTF-8"
78FILES:locale-base-nl-nl += "${datadir}/i18n/locales/musl/nl_NL.UTF-8"
79FILES:locale-base-pt-br += "${datadir}/i18n/locales/musl/pt_BR.UTF-8"
Andrew Geisslerd5838332022-05-27 11:33:10 -050080FILES:locale-base-pt-pt += "${datadir}/i18n/locales/musl/pt_PT.UTF-8"
Patrick Williams03907ee2022-05-01 06:28:52 -050081FILES:locale-base-ru-ru += "${datadir}/i18n/locales/musl/ru_RU.UTF-8"
Andrew Geisslerd5838332022-05-27 11:33:10 -050082FILES:locale-base-sr-rs += "${datadir}/i18n/locales/musl/sr_RS.UTF-8"
Patrick Williams03907ee2022-05-01 06:28:52 -050083FILES:locale-base-sv-se += "${datadir}/i18n/locales/musl/sv_SE.UTF-8"
84
85UPSTREAM_CHECK_COMMITS = "1"