blob: 7e70cf1f040235adb1eeac8ca12cec41e23ae242 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://www.khronos.org/vulkan/"
3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004LICENSE = "Apache-2.0"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
7
Andrew Geisslerc5535c92023-01-27 16:10:19 -06008SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=main;protocol=https;lfs=0 \
Andrew Geisslerd1e89492021-02-12 15:35:20 -06009 file://debugfix.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060010 file://0001-Do-not-use-LFS64-functions-on-linux-musl.patch;patchdir=third_party/spdlog \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060011 file://0001-Deprecate-u8string_view.patch;patchdir=third_party/spdlog \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060012 "
13
14UPSTREAM_CHECK_COMMITS = "1"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060015SRCREV = "3df7dba1b1f428f24cd9a242af78540a518f4b67"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060016
17UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
18S = "${WORKDIR}/git"
19
20REQUIRED_DISTRO_FEATURES = 'vulkan'
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050021COMPATIBLE_HOST = "(x86_64|aarch64|mips64|powerpc64|riscv64|loongarch64).*-linux"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060022
23inherit cmake features_check
24
Patrick Williams213cb262021-08-07 19:21:33 -050025FILES:${PN} += "${datadir}"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060026
27#
28# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
29# used for logging with LOGE in the code. We need to make this match the value we use
30# in the debug source remapping from CFLAGS
31#
32EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
33# Binaries built with PCH enabled don't appear reproducible, differing results were seen
34# from some builds depending on the point the PCH was compiled. Disable it to be
35# deterministic
36EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"
Patrick Williams213cb262021-08-07 19:21:33 -050037
38# This needs to be specified explicitly to avoid xcb/xlib dependencies
39EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D"