blob: 424e176cad721b8ab6fcee34cf09780539ec8f6e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc"
2HOMEPAGE = "https://github.com/cminyard/gensio"
3LICENSE = "GPL-2.0 & LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \
5 file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \
6 "
7
Andrew Geissler8fc454f2020-12-11 16:27:59 -06008SRCREV = "4ec19138aa968dea34e4bc4e022c1ad7ed4c43c0"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10SRC_URI = "git://github.com/cminyard/gensio;protocol=https \
Andrew Geissler8fc454f2020-12-11 16:27:59 -060011 file://0001-Modify-parameter-of-function-sctp_gensio_alloc.patch"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13S = "${WORKDIR}/git"
14
15inherit autotools
16
17PACKAGECONFIG ??= "openssl tcp-wrappers"
18
19PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl"
20PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers"
21PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig"
22
23EXTRA_OECONF = "--without-python"
24
25RDEPENDS_${PN} += "bash"