blob: c6159c42ba19a23a1e4208a3b947635c2fa6335b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
2failure processing, analysis, and reporting supporting kernel space, user \
3space, Python, and Java programs"
4
5HOMEPAGE = "https://github.com/abrt/satyr"
6LICENSE = "GPLv2"
7
8inherit autotools-brokensep python3native pkgconfig
9
10SRC_URI = "git://github.com/abrt/satyr.git \
11 file://0002-fix-compile-failure-against-musl-C-library.patch \
12"
Andrew Geissler8fc454f2020-12-11 16:27:59 -060013SRCREV = "8690a1f83adc5a7a83e856ebc7adf6310bbd3b9f"
Brad Bishop19323692019-04-05 15:28:33 -040014S = "${WORKDIR}/git"
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
17
18DEPENDS += " \
19 gdb \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050020 gperf-native \
21 json-c \
22 nettle \
Andrew Geissler8fc454f2020-12-11 16:27:59 -060023 glib-2.0 \
Brad Bishop19323692019-04-05 15:28:33 -040024"
25
Brad Bishop26bdd442019-08-16 17:08:17 -040026PACKAGES += "python3-${BPN}"
27FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
Brad Bishop19323692019-04-05 15:28:33 -040028
29PACKAGECONFIG ??= "python3 rpm"
Brad Bishop19323692019-04-05 15:28:33 -040030PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
31PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
32
33do_configure_prepend() {
34 ${S}/gen-version
35}