blob: b828927599f5b2dbed8dc97bd36e299272f49437 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "File type identification using libmagic"
2DESCRIPTION = "This module uses ctypes to access the libmagic file type \
3 identification library. It makes use of the local magic database and supports \
4 both textual and MIME-type output."
5HOMEPAGE = "http://github.com/ahupp/python-magic"
6
7LICENSE = "MIT"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06008LIC_FILES_CHKSUM = "file://LICENSE;md5=61495c152d794e6be5799a9edca149e3"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10PYPI_PACKAGE = "python-magic"
11
12inherit pypi setuptools3
13
Andrew Geissler90fd73c2021-03-05 15:25:55 -060014SRC_URI[sha256sum] = "ca884349f2c92ce830e3f498c5b7c7051fe2942c3ee4332f65213b8ebff15a62"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
Andrew Geissler5a43b432020-06-13 10:46:56 -050016RDEPENDS_${PN} += "file \
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-io \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060019 ${PYTHON_PN}-logging \
Andrew Geissler5a43b432020-06-13 10:46:56 -050020 ${PYTHON_PN}-shell"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22BBCLASSEXTEND = "native"