blob: 1dcb43b5e1bbc751ae044b9ae0fe0ddc23ff48e4 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
Andrew Geissler09209ee2020-12-13 08:44:15 -060018GIR_MESON_ENABLE_FLAG = "enabled"
19GIR_MESON_DISABLE_FLAG = "disabled"
20
Andrew Geissler90fd73c2021-03-05 15:25:55 -060021SRC_URI[archive.sha256sum] = "d21f8b30dc8abdfc55de25656ecb88dc1105eeeb315e5e2a980dcef8010c2c80"
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
23DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
24
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
26 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
27
28PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
29PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
30PACKAGECONFIG[thai] = ",,libthai"
31
32GTKDOC_MESON_OPTION = "gtk_doc"
33GIR_MESON_OPTION = 'introspection'
34
Andrew Geissler09209ee2020-12-13 08:44:15 -060035do_configure_prepend() {
36 chmod +x ${S}/tests/*.py
37}
38
Andrew Geissler82c905d2020-04-13 13:39:40 -050039do_configure_prepend_toolchain-clang() {
40 sed -i -e "/Werror=implicit-fallthrough/d" ${S}/meson.build
41}
42
43LEAD_SONAME = "libpango-1.0*"
44
45FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
46
47RDEPENDS_${PN}-ptest += "cantarell-fonts"
48RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
49
50RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
51 pango-module-basic-fc pango-module-arabic-lang"
52
53BBCLASSEXTEND = "native nativesdk"