blob: 15f394e13e9a53b57ce6f0898297b4b57c3ae17c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Linear Algebra PACKage"
2URL = "http://www.netlib.org/lapack"
3LICENSE = "BSD-3-Clause"
Patrick Williams03907ee2022-05-01 06:28:52 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=a32c99f24d097c72d1857e533b55642b"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005
6# Recipe needs FORTRAN support (copied from conf/local.conf.sample.extended)
7# Enabling FORTRAN
8# Note this is not officially supported and is just illustrated here to
9# show an example of how it can be done
10# You'll also need your fortran recipe to depend on libgfortran
Patrick Williams213cb262021-08-07 19:21:33 -050011#FORTRAN:forcevariable = ",fortran"
12#RUNTIMETARGET:append:pn-gcc-runtime = " libquadmath"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14DEPENDS = "libgfortran"
15
Patrick Williams03907ee2022-05-01 06:28:52 -050016SRCREV = "32b062a33352e05771dcc01b981ebe961bf2e42f"
Andrew Geissler595f6302022-01-24 19:11:47 +000017SRC_URI = "git://github.com/Reference-LAPACK/lapack.git;protocol=https;branch=master"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018S = "${WORKDIR}/git"
19
Patrick Williams92b42cb2022-09-03 06:53:57 -050020PACKAGECONFIG ?= ""
21PACKAGECONFIG[lapacke] = "-DLAPACKE=ON,-DLAPACKE=OFF"
22
Andrew Geissler82c905d2020-04-13 13:39:40 -050023EXTRA_OECMAKE = " -DBUILD_SHARED_LIBS=ON "
24OECMAKE_GENERATOR = "Unix Makefiles"
25
26inherit cmake pkgconfig
27EXCLUDE_FROM_WORLD = "1"