blob: e9d664750c34ea330f6955a3dddc8604b2733f2a [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
Patrick Williamsf1e5d692016-03-30 15:21:19 -05007# Class for signing package feeds
8#
9# Related configuration variables that will be used after this class is
10# iherited:
11# PACKAGE_FEED_PASSPHRASE_FILE
12# Path to a file containing the passphrase of the signing key.
13# PACKAGE_FEED_GPG_NAME
14# Name of the key to sign with. May be key id or key name.
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050015# PACKAGE_FEED_GPG_BACKEND
16# Optional variable for specifying the backend to use for signing.
17# Currently the only available option is 'local', i.e. local signing
18# on the build host.
19# PACKAGE_FEED_GPG_SIGNATURE_TYPE
20# Optional variable for specifying the type of gpg signature, can be:
21# 1. Ascii armored (ASC), default if not set
22# 2. Binary (BIN)
23# This variable is only available for IPK feeds. It is ignored on
24# other packaging backends.
Patrick Williamsf1e5d692016-03-30 15:21:19 -050025# GPG_BIN
26# Optional variable for specifying the gpg binary/wrapper to use for
27# signing.
28# GPG_PATH
29# Optional variable for specifying the gnupg "home" directory:
30#
31inherit sanity
32
33PACKAGE_FEED_SIGN = '1'
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050034PACKAGE_FEED_GPG_BACKEND ?= 'local'
35PACKAGE_FEED_GPG_SIGNATURE_TYPE ?= 'ASC'
Patrick Williams03907ee2022-05-01 06:28:52 -050036PACKAGEINDEXDEPS += "gnupg-native:do_populate_sysroot"
Patrick Williamsf1e5d692016-03-30 15:21:19 -050037
Brad Bishopd7bf8c12018-02-25 22:55:05 -050038# Make feed signing key to be present in rootfs
Patrick Williams213cb262021-08-07 19:21:33 -050039FEATURE_PACKAGES_package-management:append = " signing-keys-packagefeed"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040
Patrick Williamsf1e5d692016-03-30 15:21:19 -050041python () {
42 # Check sanity of configuration
43 for var in ('PACKAGE_FEED_GPG_NAME', 'PACKAGE_FEED_GPG_PASSPHRASE_FILE'):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050044 if not d.getVar(var):
Patrick Williamsf1e5d692016-03-30 15:21:19 -050045 raise_sanity_error("You need to define %s in the config" % var, d)
46
Brad Bishop6e60e8b2018-02-01 10:27:11 -050047 sigtype = d.getVar("PACKAGE_FEED_GPG_SIGNATURE_TYPE")
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050048 if sigtype.upper() != "ASC" and sigtype.upper() != "BIN":
49 raise_sanity_error("Bad value for PACKAGE_FEED_GPG_SIGNATURE_TYPE (%s), use either ASC or BIN" % sigtype)
Patrick Williamsf1e5d692016-03-30 15:21:19 -050050}
51
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050052do_package_index[depends] += "signing-keys:do_deploy"
Brad Bishop316dfdd2018-06-25 12:45:53 -040053do_rootfs[depends] += "signing-keys:do_populate_sysroot gnupg-native:do_populate_sysroot"