blob: a1b0ee2883621e3fca3520a772cdabb619118690 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Self-hosting"
6DESCRIPTION = "Packages required to run the build system"
7PR = "r13"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
Brad Bishop00e122a2019-10-05 11:10:57 -04009PACKAGE_ARCH = "${TUNE_PKGARCH}"
10
Brad Bishop6dbb3162019-11-25 09:41:34 -050011inherit packagegroup features_check
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012# rdepends on libx11-dev
13REQUIRED_DISTRO_FEATURES = "x11"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015# rdepends on libgl
16REQUIRED_DISTRO_FEATURES += "opengl"
17
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018PACKAGES = "\
19 packagegroup-self-hosted \
20 packagegroup-self-hosted-debug \
21 packagegroup-self-hosted-sdk \
22 packagegroup-self-hosted-extended \
23 packagegroup-self-hosted-graphics \
24 packagegroup-self-hosted-host-tools \
25 "
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:packagegroup-self-hosted = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028 packagegroup-self-hosted-debug \
29 packagegroup-self-hosted-sdk \
30 packagegroup-self-hosted-extended \
31 packagegroup-self-hosted-graphics \
32 packagegroup-self-hosted-host-tools \
33 "
34
Patrick Williams213cb262021-08-07 19:21:33 -050035RDEPENDS:packagegroup-self-hosted-host-tools = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036 e2fsprogs \
37 e2fsprogs-e2fsck \
38 e2fsprogs-mke2fs \
39 e2fsprogs-tune2fs \
40 hdparm \
41 iptables \
Brad Bishop79641f22019-09-10 07:20:22 -040042 lsb-release \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043 mc \
44 mc-fish \
45 mc-helpers \
46 mc-helpers-perl \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050047 parted \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050048 ${PSEUDO} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049 screen \
50 "
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050051PSEUDO = "pseudo"
Patrick Williams213cb262021-08-07 19:21:33 -050052PSEUDO:libc-musl = ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053
Patrick Williams213cb262021-08-07 19:21:33 -050054RRECOMMENDS:packagegroup-self-hosted-host-tools = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055 kernel-module-tun \
56 kernel-module-iptable-raw \
57 kernel-module-iptable-nat \
58 kernel-module-iptable-mangle \
59 kernel-module-iptable-filter \
60 "
61
Patrick Williams213cb262021-08-07 19:21:33 -050062RDEPENDS:packagegroup-self-hosted-sdk = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050063 autoconf \
64 automake \
65 binutils \
66 binutils-symlinks \
67 ccache \
68 coreutils \
69 cpp \
70 cpp-symlinks \
71 distcc \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050072 file \
73 findutils \
74 g++ \
75 g++-symlinks \
76 gcc \
77 gcc-symlinks \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050078 ldd \
79 less \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050080 libstdc++ \
81 libstdc++-dev \
82 libtool \
83 make \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084 perl-module-re \
85 perl-module-text-wrap \
86 pkgconfig \
87 quilt \
88 sed \
89 "
Patrick Williams213cb262021-08-07 19:21:33 -050090RDEPENDS:packagegroup-self-hosted-sdk:append:mingw32 = "\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080091 libssp \
92 libssp-dev \
93 libssp-staticdev \
94 "
95# rpcsvc-proto: for rpcgen
Patrick Williams213cb262021-08-07 19:21:33 -050096RDEPENDS:packagegroup-self-hosted-sdk:append:libc-glibc = "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050097 glibc-gconv-ibm850 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050098 glibc-utils \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080099 rpcsvc-proto \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500100 "
Patrick Williams92b42cb2022-09-03 06:53:57 -0500101
102STRACE = "strace"
103STRACE:riscv32 = ""
Patrick Williams213cb262021-08-07 19:21:33 -0500104RDEPENDS:packagegroup-self-hosted-debug = " \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500105 gdb \
106 gdbserver \
107 rsync \
Patrick Williams92b42cb2022-09-03 06:53:57 -0500108 ${STRACE} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500109 tcf-agent"
110
111
Patrick Williams213cb262021-08-07 19:21:33 -0500112RDEPENDS:packagegroup-self-hosted-extended = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500113 bzip2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500114 chrpath \
115 cpio \
116 curl \
117 diffstat \
118 diffutils \
119 elfutils \
120 expat \
121 gawk \
122 gdbm \
123 gettext \
124 gettext-runtime \
125 git \
126 git-perltools \
127 grep \
128 groff \
129 gzip \
130 settings-daemon \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500131 libaio \
132 libusb1 \
133 libxml2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500134 lsof \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500135 man \
136 man-pages \
137 mdadm \
138 minicom \
139 mtools \
140 ncurses \
141 ncurses-terminfo-base \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500142 nfs-utils \
143 nfs-utils-client \
144 openssl \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500145 openssh-scp \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500146 openssh-sftp-server \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500147 openssh-ssh \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500148 opkg \
149 opkg-utils \
150 patch \
151 perl \
152 perl-dev \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500153 perl-misc \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500154 perl-modules \
155 perl-pod \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600156 python3 \
157 python3-modules \
158 python3-git \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500159 quota \
160 readline \
161 rpm \
162 setserial \
163 socat \
164 subversion \
165 sudo \
166 sysstat \
167 tar \
168 tcl \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500169 texinfo \
170 unzip \
171 usbutils \
172 watchdog \
173 wget \
174 which \
175 xinetd \
176 zip \
177 zlib \
178 xz \
179 "
180
181
Patrick Williams213cb262021-08-07 19:21:33 -0500182RDEPENDS:packagegroup-self-hosted-graphics = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500183 builder \
184 libgl \
185 libgl-dev \
186 libglu \
187 libglu-dev \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500188 libx11-dev \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600189 adwaita-icon-theme \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500190 xdg-utils \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600191 l3afpad \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500192 pcmanfm \
193 vte \
194 "