blob: b8385893752f5406b55b9c0b50a19651af110f7d [file] [log] [blame]
Brad Bishopb1e88402017-01-11 11:12:32 -05001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Brad Bishop4186efb2017-01-11 15:30:07 -05008inherit autotools pkgconfig obmc-phosphor-systemd
9
10SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
Brad Bishopb1e88402017-01-11 11:12:32 -050011
12DEPENDS += "autoconf-archive-native"
Brad Bishop6d105112017-02-20 14:36:31 -050013DEPENDS += " \
14 sdbusplus \
15 phosphor-dbus-interfaces \
16 phosphor-logging \
17 "
18
Brad Bishopb1e88402017-01-11 11:12:32 -050019
20RDEPENDS_${PN} += "\
Brad Bishop6d105112017-02-20 14:36:31 -050021 sdbusplus \
22 phosphor-dbus-interfaces \
23 phosphor-logging \
Brad Bishopb1e88402017-01-11 11:12:32 -050024 "
25
Brad Bishop3217b272017-02-22 20:50:13 -050026RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
27
Brad Bishopb1e88402017-01-11 11:12:32 -050028SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
Brad Bishop4186efb2017-01-11 15:30:07 -050029SRC_URI += "file://70-hwmon.rules"
Brandon Wyman7cae3ea2017-06-21 16:32:56 -050030SRC_URI += "file://70-iio.rules"
Brad Bishopb1e88402017-01-11 11:12:32 -050031
Patrick Williams92e08712017-08-04 12:40:04 -050032SRCREV = "e49b6a03b1fcabe0ddc8b6551e667d03b03eb182"
Brad Bishopb1e88402017-01-11 11:12:32 -050033
34S = "${WORKDIR}/git"
Brad Bishop4186efb2017-01-11 15:30:07 -050035
36do_install_append() {
37
Brad Bishop2b9921e2017-01-26 09:12:57 -050038 install -d ${D}/${base_libdir}/udev/rules.d/
39 install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
Brandon Wyman7cae3ea2017-06-21 16:32:56 -050040 install ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/
Brad Bishop4186efb2017-01-11 15:30:07 -050041}