blob: 8e03039aeb6701eeff7fed2c080dc229c26f7ca3 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001BUILDSTATS_BASE = "${TMPDIR}/buildstats/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05002
3################################################################################
4# Build statistics gathering.
5#
6# The CPU and Time gathering/tracking functions and bbevent inspiration
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05007# were written by Christopher Larson.
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008#
9################################################################################
10
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050011def get_buildprocess_cputime(pid):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012 with open("/proc/%d/stat" % pid, "r") as f:
13 fields = f.readline().rstrip().split()
14 # 13: utime, 14: stime, 15: cutime, 16: cstime
15 return sum(int(field) for field in fields[13:16])
16
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017def get_process_cputime(pid):
18 import resource
19 with open("/proc/%d/stat" % pid, "r") as f:
20 fields = f.readline().rstrip().split()
21 stats = {
22 'utime' : fields[13],
23 'stime' : fields[14],
24 'cutime' : fields[15],
25 'cstime' : fields[16],
26 }
27 iostats = {}
28 if os.path.isfile("/proc/%d/io" % pid):
29 with open("/proc/%d/io" % pid, "r") as f:
30 while True:
31 i = f.readline().strip()
32 if not i:
33 break
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034 if not ":" in i:
35 # one more extra line is appended (empty or containing "0")
36 # most probably due to race condition in kernel while
37 # updating IO stats
38 break
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050039 i = i.split(": ")
40 iostats[i[0]] = i[1]
41 resources = resource.getrusage(resource.RUSAGE_SELF)
42 childres = resource.getrusage(resource.RUSAGE_CHILDREN)
43 return stats, iostats, resources, childres
44
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045def get_cputime():
46 with open("/proc/stat", "r") as f:
47 fields = f.readline().rstrip().split()[1:]
48 return sum(int(field) for field in fields)
49
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050050def set_timedata(var, d, server_time):
51 d.setVar(var, server_time)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050053def get_timedata(var, d, end_time):
54 oldtime = d.getVar(var, False)
55 if oldtime is None:
Patrick Williamsc124f4f2015-09-15 14:41:29 -050056 return
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050057 return end_time - oldtime
Patrick Williamsc124f4f2015-09-15 14:41:29 -050058
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050059def set_buildtimedata(var, d):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050060 import time
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050061 time = time.time()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062 cputime = get_cputime()
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050063 proctime = get_buildprocess_cputime(os.getpid())
64 d.setVar(var, (time, cputime, proctime))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050066def get_buildtimedata(var, d):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050067 import time
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050068 timedata = d.getVar(var, False)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050069 if timedata is None:
70 return
71 oldtime, oldcpu, oldproc = timedata
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050072 procdiff = get_buildprocess_cputime(os.getpid()) - oldproc
Patrick Williamsc124f4f2015-09-15 14:41:29 -050073 cpudiff = get_cputime() - oldcpu
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050074 end_time = time.time()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050075 timediff = end_time - oldtime
76 if cpudiff > 0:
77 cpuperc = float(procdiff) * 100 / cpudiff
78 else:
79 cpuperc = None
80 return timediff, cpuperc
81
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050082def write_task_data(status, logfile, e, d):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050083 with open(os.path.join(logfile), "a") as f:
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050084 elapsedtime = get_timedata("__timedata_task", d, e.time)
85 if elapsedtime:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050086 f.write(d.expand("${PF}: %s\n" % e.task))
87 f.write(d.expand("Elapsed time: %0.2f seconds\n" % elapsedtime))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050088 cpu, iostats, resources, childres = get_process_cputime(os.getpid())
Patrick Williamsc124f4f2015-09-15 14:41:29 -050089 if cpu:
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050090 f.write("utime: %s\n" % cpu['utime'])
91 f.write("stime: %s\n" % cpu['stime'])
92 f.write("cutime: %s\n" % cpu['cutime'])
93 f.write("cstime: %s\n" % cpu['cstime'])
94 for i in iostats:
95 f.write("IO %s: %s\n" % (i, iostats[i]))
96 rusages = ["ru_utime", "ru_stime", "ru_maxrss", "ru_minflt", "ru_majflt", "ru_inblock", "ru_oublock", "ru_nvcsw", "ru_nivcsw"]
97 for i in rusages:
98 f.write("rusage %s: %s\n" % (i, getattr(resources, i)))
99 for i in rusages:
100 f.write("Child rusage %s: %s\n" % (i, getattr(childres, i)))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500101 if status == "passed":
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500102 f.write("Status: PASSED \n")
103 else:
104 f.write("Status: FAILED \n")
105 f.write("Ended: %0.2f \n" % e.time)
106
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600107def write_host_data(logfile, e, d):
108 import subprocess, os, datetime
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500109 # minimum time allowed for each command to run, in seconds
110 time_threshold = 0.5
111 # the total number of commands
112 num_cmds = 0
113 # interval at which data will be logged
114 interval = int(d.getVar("BB_HEARTBEAT_EVENT", False))
115 # the commands to be run at each interval
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600116 cmds = d.getVar('BB_LOG_HOST_STAT_CMDS')
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500117 # if no commands are passed, issue a warning and return
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600118 if cmds is None:
119 d.setVar("BB_LOG_HOST_STAT_ON_INTERVAL", "0")
120 d.setVar("BB_LOG_HOST_STAT_ON_FAILURE", "0")
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500121 bb.warn("buildstats: Collecting host data failed. Set BB_LOG_HOST_STAT_CMDS=\"command1 ; command2 ; ... \" in conf/local.conf\n")
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600122 return
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500123 # find the total commands
124 c_san = []
125 for cmd in cmds.split(";"):
126 if len(cmd) == 0:
127 continue
128 num_cmds += 1
129 c_san.append(cmd)
130 if num_cmds <= 0:
131 d.setVar("BB_LOG_HOST_STAT_ON_INTERVAL", "0")
132 d.setVar("BB_LOG_HOST_STAT_ON_FAILURE", "0")
133 return
134
135 # return if the interval is not enough to run all commands within the specified BB_HEARTBEAT_EVENT interval
136 limit = interval / num_cmds
137 if limit <= time_threshold:
138 d.setVar("BB_LOG_HOST_STAT_ON_INTERVAL", "0")
139 d.setVar("BB_LOG_HOST_STAT_ON_FAILURE", "0")
140 bb.warn("buildstats: Collecting host data failed. BB_HEARTBEAT_EVENT interval not enough to run the specified commands. HINT: Increase value of BB_HEARTBEAT_EVENT in conf/local.conf\n")
141 return
142
143 # set the environment variables
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600144 path = d.getVar("PATH")
145 opath = d.getVar("BB_ORIGENV", False).getVar("PATH")
146 ospath = os.environ['PATH']
147 os.environ['PATH'] = path + ":" + opath + ":" + ospath
148 with open(logfile, "a") as f:
149 f.write("Event Time: %f\nDate: %s\n" % (e.time, datetime.datetime.now()))
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500150 for c in c_san:
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600151 try:
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500152 output = subprocess.check_output(c.split(), stderr=subprocess.STDOUT, timeout=limit).decode('utf-8')
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600153 except (subprocess.CalledProcessError, subprocess.TimeoutExpired, FileNotFoundError) as err:
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500154 output = "Error running command: %s\n%s\n" % (c, err)
155 f.write("%s\n%s\n" % (c, output))
156 # reset the environment
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600157 os.environ['PATH'] = ospath
158
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500159python run_buildstats () {
160 import bb.build
161 import bb.event
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500162 import time, subprocess, platform
163
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500164 bn = d.getVar('BUILDNAME')
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600165 ########################################################################
166 # bitbake fires HeartbeatEvent even before a build has been
167 # triggered, causing BUILDNAME to be None
168 ########################################################################
169 if bn is not None:
170 bsdir = os.path.join(d.getVar('BUILDSTATS_BASE'), bn)
171 taskdir = os.path.join(bsdir, d.getVar('PF'))
172 if isinstance(e, bb.event.HeartbeatEvent) and bb.utils.to_boolean(d.getVar("BB_LOG_HOST_STAT_ON_INTERVAL")):
173 bb.utils.mkdirhier(bsdir)
174 write_host_data(os.path.join(bsdir, "host_stats"), e, d)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500175
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500176 if isinstance(e, bb.event.BuildStarted):
177 ########################################################################
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500178 # If the kernel was not configured to provide I/O statistics, issue
179 # a one time warning.
180 ########################################################################
181 if not os.path.isfile("/proc/%d/io" % os.getpid()):
182 bb.warn("The Linux kernel on your build host was not configured to provide process I/O statistics. (CONFIG_TASK_IO_ACCOUNTING is not set)")
183
184 ########################################################################
185 # at first pass make the buildstats hierarchy and then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500186 # set the buildname
187 ########################################################################
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500188 bb.utils.mkdirhier(bsdir)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500189 set_buildtimedata("__timedata_build", d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500190 build_time = os.path.join(bsdir, "build_stats")
191 # write start of build into build_time
192 with open(build_time, "a") as f:
193 host_info = platform.uname()
194 f.write("Host Info: ")
195 for x in host_info:
196 if x:
197 f.write(x + " ")
198 f.write("\n")
Andrew Geissler4ed12e12020-06-05 18:00:41 -0500199 f.write("Build Started: %0.2f \n" % d.getVar('__timedata_build', False)[0])
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500200
201 elif isinstance(e, bb.event.BuildCompleted):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500202 build_time = os.path.join(bsdir, "build_stats")
203 with open(build_time, "a") as f:
204 ########################################################################
205 # Write build statistics for the build
206 ########################################################################
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500207 timedata = get_buildtimedata("__timedata_build", d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500208 if timedata:
209 time, cpu = timedata
210 # write end of build and cpu used into build_time
211 f.write("Elapsed time: %0.2f seconds \n" % (time))
212 if cpu:
213 f.write("CPU usage: %0.1f%% \n" % cpu)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500214
215 if isinstance(e, bb.build.TaskStarted):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500216 set_timedata("__timedata_task", d, e.time)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500217 bb.utils.mkdirhier(taskdir)
218 # write into the task event file the name and start time
219 with open(os.path.join(taskdir, e.task), "a") as f:
220 f.write("Event: %s \n" % bb.event.getName(e))
221 f.write("Started: %0.2f \n" % e.time)
222
223 elif isinstance(e, bb.build.TaskSucceeded):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500224 write_task_data("passed", os.path.join(taskdir, e.task), e, d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500225 if e.task == "do_rootfs":
226 bs = os.path.join(bsdir, "build_stats")
227 with open(bs, "a") as f:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500228 rootfs = d.getVar('IMAGE_ROOTFS')
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600229 if os.path.isdir(rootfs):
230 try:
231 rootfs_size = subprocess.check_output(["du", "-sh", rootfs],
232 stderr=subprocess.STDOUT).decode('utf-8')
233 f.write("Uncompressed Rootfs size: %s" % rootfs_size)
234 except subprocess.CalledProcessError as err:
235 bb.warn("Failed to get rootfs size: %s" % err.output.decode('utf-8'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500236
237 elif isinstance(e, bb.build.TaskFailed):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500238 # Can have a failure before TaskStarted so need to mkdir here too
239 bb.utils.mkdirhier(taskdir)
240 write_task_data("failed", os.path.join(taskdir, e.task), e, d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500241 ########################################################################
242 # Lets make things easier and tell people where the build failed in
243 # build_status. We do this here because BuildCompleted triggers no
244 # matter what the status of the build actually is
245 ########################################################################
246 build_status = os.path.join(bsdir, "build_stats")
247 with open(build_status, "a") as f:
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500248 f.write(d.expand("Failed at: ${PF} at task: %s \n" % e.task))
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600249 if bb.utils.to_boolean(d.getVar("BB_LOG_HOST_STAT_ON_FAILURE")):
250 write_host_data(build_status, e, d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500251}
252
253addhandler run_buildstats
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600254run_buildstats[eventmask] = "bb.event.BuildStarted bb.event.BuildCompleted bb.event.HeartbeatEvent bb.build.TaskStarted bb.build.TaskSucceeded bb.build.TaskFailed"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500255
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500256python runqueue_stats () {
257 import buildstats
258 from bb import event, runqueue
259 # We should not record any samples before the first task has started,
260 # because that's the first activity shown in the process chart.
261 # Besides, at that point we are sure that the build variables
262 # are available that we need to find the output directory.
263 # The persistent SystemStats is stored in the datastore and
264 # closed when the build is done.
265 system_stats = d.getVar('_buildstats_system_stats', False)
266 if not system_stats and isinstance(e, (bb.runqueue.sceneQueueTaskStarted, bb.runqueue.runQueueTaskStarted)):
267 system_stats = buildstats.SystemStats(d)
268 d.setVar('_buildstats_system_stats', system_stats)
269 if system_stats:
270 # Ensure that we sample at important events.
271 done = isinstance(e, bb.event.BuildCompleted)
272 system_stats.sample(e, force=done)
273 if done:
274 system_stats.close()
275 d.delVar('_buildstats_system_stats')
276}
277
278addhandler runqueue_stats
279runqueue_stats[eventmask] = "bb.runqueue.sceneQueueTaskStarted bb.runqueue.runQueueTaskStarted bb.event.HeartbeatEvent bb.event.BuildCompleted bb.event.MonitorDiskEvent"