blob: 5226e84266c769db1f244e34f5a0453cf579c7ee [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "The Bitstream Vera fonts - TTF Edition"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05002HOMEPAGE = "https://www.gnome.org/fonts/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003DESCRIPTION = "The Bitstream Vera fonts include four monospace and sans \
4faces (normal, oblique, bold, bold oblique) and two serif faces (normal \
5and bold). In addition Fontconfig/Xft2 can artificially oblique the \
6serif faces for you: this loses hinting and distorts the faces slightly, \
7but is visibly different than normal and bold, and reasonably pleasing."
8SECTION = "x11/fonts"
9LICENSE = "BitstreamVera"
10LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060011PR = "r8"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012
Andrew Geissler635e0e42020-08-21 15:58:33 -050013inherit allarch fontcache
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014
Andrew Geissler90fd73c2021-03-05 15:25:55 -060015# remove at next version upgrade or when output changes
16HASHEQUIV_HASH_VERSION .= ".1"
17
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018FONT_PACKAGES = "${PN}"
19
Brad Bishop316dfdd2018-06-25 12:45:53 -040020SRC_URI = "${GNOME_MIRROR}/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021SRC_URI[md5sum] = "bb22bd5b4675f5dbe17c6963d8c00ed6"
22SRC_URI[sha256sum] = "db5b27df7bbb318036ebdb75acd3e98f1bd6eb6608fb70a67d478cd243d178dc"
Brad Bishop316dfdd2018-06-25 12:45:53 -040023
24do_install () {
25 install -d ${D}${datadir}/fonts/ttf
26 for i in *.ttf; do
27 install -m 644 $i ${D}${datadir}/fonts/ttf
28 done
29
30 install -d ${D}${docdir}/${BPN}
31 for i in *.TXT; do
32 install -m 644 $i ${D}${docdir}/${BPN}
33 done
34}
35
36FILES_${PN} = "${datadir}/fonts"