blob: 89e3323b69e022d0199367c60dee5cd9de181db9 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Real-Time preemption testcases"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05002HOMEPAGE = "https://wiki.linuxfoundation.org/realtime/documentation/start"
3DESCRIPTION = "The main aim of the PREEMPT_RT patch is to minimize the amount of kernel code that is non-preemptible Therefore several substitution mechanisms and new mechanisms are implemented."
Patrick Williamsc0f7c042017-02-23 20:41:17 -06004SECTION = "tests"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06005DEPENDS = "linux-libc-headers virtual/libc numactl"
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006LICENSE = "GPLv2 & GPLv2+"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06007LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008
9require rt-tests.inc
10inherit ptest
11
12SRC_URI += " \
13 file://run-ptest \
14 file://rt_bmark.py \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060015 file://0001-Makefile-Allow-for-CC-and-AR-to-be-overridden.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060016 "
Brad Bishop79641f22019-09-10 07:20:22 -040017
18# rt-tests needs PI mutex support in libc
19COMPATIBLE_HOST_libc-musl = 'null'
20
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021# Do not install hwlatdetect
22EXTRA_OEMAKE += "PYLIB=''"
23
24do_install() {
25 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
26 INCLUDEDIR=${includedir}
27}
28
29do_install_ptest() {
30 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
31}
32
Brad Bishop08902b02019-08-20 09:16:51 -040033RDEPENDS_${PN}-ptest += " stress-ng python3 python3-multiprocessing python3-datetime python3-misc"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060034
35FILES_${PN} += "${prefix}/src/backfire"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060036RDEPENDS_${PN} += "bash"