blob: 960653c704651ec1460dee648aebf1d286514883 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001BUILDSTATS_BASE = "${TMPDIR}/buildstats/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05002
3################################################################################
4# Build statistics gathering.
5#
6# The CPU and Time gathering/tracking functions and bbevent inspiration
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05007# were written by Christopher Larson.
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008#
9################################################################################
10
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050011def get_buildprocess_cputime(pid):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012 with open("/proc/%d/stat" % pid, "r") as f:
13 fields = f.readline().rstrip().split()
14 # 13: utime, 14: stime, 15: cutime, 16: cstime
15 return sum(int(field) for field in fields[13:16])
16
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017def get_process_cputime(pid):
18 import resource
19 with open("/proc/%d/stat" % pid, "r") as f:
20 fields = f.readline().rstrip().split()
21 stats = {
22 'utime' : fields[13],
23 'stime' : fields[14],
24 'cutime' : fields[15],
25 'cstime' : fields[16],
26 }
27 iostats = {}
28 if os.path.isfile("/proc/%d/io" % pid):
29 with open("/proc/%d/io" % pid, "r") as f:
30 while True:
31 i = f.readline().strip()
32 if not i:
33 break
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034 if not ":" in i:
35 # one more extra line is appended (empty or containing "0")
36 # most probably due to race condition in kernel while
37 # updating IO stats
38 break
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050039 i = i.split(": ")
40 iostats[i[0]] = i[1]
41 resources = resource.getrusage(resource.RUSAGE_SELF)
42 childres = resource.getrusage(resource.RUSAGE_CHILDREN)
43 return stats, iostats, resources, childres
44
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045def get_cputime():
46 with open("/proc/stat", "r") as f:
47 fields = f.readline().rstrip().split()[1:]
48 return sum(int(field) for field in fields)
49
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050050def set_timedata(var, d, server_time):
51 d.setVar(var, server_time)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050053def get_timedata(var, d, end_time):
54 oldtime = d.getVar(var, False)
55 if oldtime is None:
Patrick Williamsc124f4f2015-09-15 14:41:29 -050056 return
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050057 return end_time - oldtime
Patrick Williamsc124f4f2015-09-15 14:41:29 -050058
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050059def set_buildtimedata(var, d):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050060 import time
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050061 time = time.time()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062 cputime = get_cputime()
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050063 proctime = get_buildprocess_cputime(os.getpid())
64 d.setVar(var, (time, cputime, proctime))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050066def get_buildtimedata(var, d):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050067 import time
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050068 timedata = d.getVar(var, False)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050069 if timedata is None:
70 return
71 oldtime, oldcpu, oldproc = timedata
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050072 procdiff = get_buildprocess_cputime(os.getpid()) - oldproc
Patrick Williamsc124f4f2015-09-15 14:41:29 -050073 cpudiff = get_cputime() - oldcpu
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050074 end_time = time.time()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050075 timediff = end_time - oldtime
76 if cpudiff > 0:
77 cpuperc = float(procdiff) * 100 / cpudiff
78 else:
79 cpuperc = None
80 return timediff, cpuperc
81
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050082def write_task_data(status, logfile, e, d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050083 bn = d.getVar('BUILDNAME')
84 bsdir = os.path.join(d.getVar('BUILDSTATS_BASE'), bn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050085 with open(os.path.join(logfile), "a") as f:
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050086 elapsedtime = get_timedata("__timedata_task", d, e.time)
87 if elapsedtime:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050088 f.write(d.expand("${PF}: %s\n" % e.task))
89 f.write(d.expand("Elapsed time: %0.2f seconds\n" % elapsedtime))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050090 cpu, iostats, resources, childres = get_process_cputime(os.getpid())
Patrick Williamsc124f4f2015-09-15 14:41:29 -050091 if cpu:
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050092 f.write("utime: %s\n" % cpu['utime'])
93 f.write("stime: %s\n" % cpu['stime'])
94 f.write("cutime: %s\n" % cpu['cutime'])
95 f.write("cstime: %s\n" % cpu['cstime'])
96 for i in iostats:
97 f.write("IO %s: %s\n" % (i, iostats[i]))
98 rusages = ["ru_utime", "ru_stime", "ru_maxrss", "ru_minflt", "ru_majflt", "ru_inblock", "ru_oublock", "ru_nvcsw", "ru_nivcsw"]
99 for i in rusages:
100 f.write("rusage %s: %s\n" % (i, getattr(resources, i)))
101 for i in rusages:
102 f.write("Child rusage %s: %s\n" % (i, getattr(childres, i)))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500103 if status is "passed":
104 f.write("Status: PASSED \n")
105 else:
106 f.write("Status: FAILED \n")
107 f.write("Ended: %0.2f \n" % e.time)
108
109python run_buildstats () {
110 import bb.build
111 import bb.event
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500112 import time, subprocess, platform
113
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500114 bn = d.getVar('BUILDNAME')
115 bsdir = os.path.join(d.getVar('BUILDSTATS_BASE'), bn)
116 taskdir = os.path.join(bsdir, d.getVar('PF'))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500117
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500118 if isinstance(e, bb.event.BuildStarted):
119 ########################################################################
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500120 # If the kernel was not configured to provide I/O statistics, issue
121 # a one time warning.
122 ########################################################################
123 if not os.path.isfile("/proc/%d/io" % os.getpid()):
124 bb.warn("The Linux kernel on your build host was not configured to provide process I/O statistics. (CONFIG_TASK_IO_ACCOUNTING is not set)")
125
126 ########################################################################
127 # at first pass make the buildstats hierarchy and then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500128 # set the buildname
129 ########################################################################
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500130 bb.utils.mkdirhier(bsdir)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500131 set_buildtimedata("__timedata_build", d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500132 build_time = os.path.join(bsdir, "build_stats")
133 # write start of build into build_time
134 with open(build_time, "a") as f:
135 host_info = platform.uname()
136 f.write("Host Info: ")
137 for x in host_info:
138 if x:
139 f.write(x + " ")
140 f.write("\n")
141 f.write("Build Started: %0.2f \n" % time.time())
142
143 elif isinstance(e, bb.event.BuildCompleted):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500144 build_time = os.path.join(bsdir, "build_stats")
145 with open(build_time, "a") as f:
146 ########################################################################
147 # Write build statistics for the build
148 ########################################################################
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500149 timedata = get_buildtimedata("__timedata_build", d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500150 if timedata:
151 time, cpu = timedata
152 # write end of build and cpu used into build_time
153 f.write("Elapsed time: %0.2f seconds \n" % (time))
154 if cpu:
155 f.write("CPU usage: %0.1f%% \n" % cpu)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500156
157 if isinstance(e, bb.build.TaskStarted):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500158 set_timedata("__timedata_task", d, e.time)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500159 bb.utils.mkdirhier(taskdir)
160 # write into the task event file the name and start time
161 with open(os.path.join(taskdir, e.task), "a") as f:
162 f.write("Event: %s \n" % bb.event.getName(e))
163 f.write("Started: %0.2f \n" % e.time)
164
165 elif isinstance(e, bb.build.TaskSucceeded):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500166 write_task_data("passed", os.path.join(taskdir, e.task), e, d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500167 if e.task == "do_rootfs":
168 bs = os.path.join(bsdir, "build_stats")
169 with open(bs, "a") as f:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500170 rootfs = d.getVar('IMAGE_ROOTFS')
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600171 if os.path.isdir(rootfs):
172 try:
173 rootfs_size = subprocess.check_output(["du", "-sh", rootfs],
174 stderr=subprocess.STDOUT).decode('utf-8')
175 f.write("Uncompressed Rootfs size: %s" % rootfs_size)
176 except subprocess.CalledProcessError as err:
177 bb.warn("Failed to get rootfs size: %s" % err.output.decode('utf-8'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500178
179 elif isinstance(e, bb.build.TaskFailed):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500180 # Can have a failure before TaskStarted so need to mkdir here too
181 bb.utils.mkdirhier(taskdir)
182 write_task_data("failed", os.path.join(taskdir, e.task), e, d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500183 ########################################################################
184 # Lets make things easier and tell people where the build failed in
185 # build_status. We do this here because BuildCompleted triggers no
186 # matter what the status of the build actually is
187 ########################################################################
188 build_status = os.path.join(bsdir, "build_stats")
189 with open(build_status, "a") as f:
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500190 f.write(d.expand("Failed at: ${PF} at task: %s \n" % e.task))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500191}
192
193addhandler run_buildstats
194run_buildstats[eventmask] = "bb.event.BuildStarted bb.event.BuildCompleted bb.build.TaskStarted bb.build.TaskSucceeded bb.build.TaskFailed"
195
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500196python runqueue_stats () {
197 import buildstats
198 from bb import event, runqueue
199 # We should not record any samples before the first task has started,
200 # because that's the first activity shown in the process chart.
201 # Besides, at that point we are sure that the build variables
202 # are available that we need to find the output directory.
203 # The persistent SystemStats is stored in the datastore and
204 # closed when the build is done.
205 system_stats = d.getVar('_buildstats_system_stats', False)
206 if not system_stats and isinstance(e, (bb.runqueue.sceneQueueTaskStarted, bb.runqueue.runQueueTaskStarted)):
207 system_stats = buildstats.SystemStats(d)
208 d.setVar('_buildstats_system_stats', system_stats)
209 if system_stats:
210 # Ensure that we sample at important events.
211 done = isinstance(e, bb.event.BuildCompleted)
212 system_stats.sample(e, force=done)
213 if done:
214 system_stats.close()
215 d.delVar('_buildstats_system_stats')
216}
217
218addhandler runqueue_stats
219runqueue_stats[eventmask] = "bb.runqueue.sceneQueueTaskStarted bb.runqueue.runQueueTaskStarted bb.event.HeartbeatEvent bb.event.BuildCompleted bb.event.MonitorDiskEvent"