blob: c00d2910be1c1cc515fa529bdd67d69f1a8869d5 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001# This class is used to check recipes against public CVEs.
2#
3# In order to use this class just inherit the class in the
4# local.conf file and it will add the cve_check task for
5# every recipe. The task can be used per recipe, per image,
6# or using the special cases "world" and "universe". The
7# cve_check task will print a warning for every unpatched
8# CVE found and generate a file in the recipe WORKDIR/cve
9# directory. If an image is build it will generate a report
10# in DEPLOY_DIR_IMAGE for all the packages used.
11#
12# Example:
13# bitbake -c cve_check openssl
14# bitbake core-image-sato
15# bitbake -k -c cve_check universe
16#
17# DISCLAIMER
18#
19# This class/tool is meant to be used as support and not
20# the only method to check against CVEs. Running this tool
21# doesn't guarantee your packages are free of CVEs.
22
Brad Bishop37a0e4d2017-12-04 01:01:44 -050023# The product name that the CVE database uses. Defaults to BPN, but may need to
24# be overriden per recipe (for example tiff.bb sets CVE_PRODUCT=libtiff).
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025CVE_PRODUCT ??= "${BPN}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040026CVE_VERSION ??= "${PV}"
Brad Bishop37a0e4d2017-12-04 01:01:44 -050027
Patrick Williamsc0f7c042017-02-23 20:41:17 -060028CVE_CHECK_DB_DIR ?= "${DL_DIR}/CVE_CHECK"
Brad Bishop96ff1982019-08-19 13:50:42 -040029CVE_CHECK_DB_FILE ?= "${CVE_CHECK_DB_DIR}/nvdcve_1.0.db"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060030
Brad Bishop316dfdd2018-06-25 12:45:53 -040031CVE_CHECK_LOG ?= "${T}/cve.log"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060032CVE_CHECK_TMP_FILE ?= "${TMPDIR}/cve_check"
33
34CVE_CHECK_DIR ??= "${DEPLOY_DIR}/cve"
35CVE_CHECK_MANIFEST ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.cve"
36CVE_CHECK_COPY_FILES ??= "1"
37CVE_CHECK_CREATE_MANIFEST ??= "1"
38
39# Whitelist for packages (PN)
Brad Bishop96ff1982019-08-19 13:50:42 -040040CVE_CHECK_PN_WHITELIST ?= ""
Patrick Williamsc0f7c042017-02-23 20:41:17 -060041
Brad Bishop96ff1982019-08-19 13:50:42 -040042# Whitelist for CVE. If a CVE is found, then it is considered patched.
43# The value is a string containing space separated CVE values:
44#
45# CVE_CHECK_WHITELIST = 'CVE-2014-2524 CVE-2018-1234'
46#
47CVE_CHECK_WHITELIST ?= ""
Patrick Williamsc0f7c042017-02-23 20:41:17 -060048
49python do_cve_check () {
50 """
51 Check recipe for patched and unpatched CVEs
52 """
53
Brad Bishop96ff1982019-08-19 13:50:42 -040054 if os.path.exists(d.getVar("CVE_CHECK_DB_FILE")):
Patrick Williamsc0f7c042017-02-23 20:41:17 -060055 patched_cves = get_patches_cves(d)
56 patched, unpatched = check_cves(d, patched_cves)
57 if patched or unpatched:
58 cve_data = get_cve_info(d, patched + unpatched)
59 cve_write_data(d, patched, unpatched, cve_data)
60 else:
Brad Bishop96ff1982019-08-19 13:50:42 -040061 bb.note("No CVE database found, skipping CVE check")
62
Patrick Williamsc0f7c042017-02-23 20:41:17 -060063}
64
65addtask cve_check after do_unpack before do_build
Brad Bishop96ff1982019-08-19 13:50:42 -040066do_cve_check[depends] = "cve-update-db-native:do_populate_cve_db"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060067do_cve_check[nostamp] = "1"
68
69python cve_check_cleanup () {
70 """
71 Delete the file used to gather all the CVE information.
72 """
73
Brad Bishop6e60e8b2018-02-01 10:27:11 -050074 bb.utils.remove(e.data.getVar("CVE_CHECK_TMP_FILE"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -060075}
76
77addhandler cve_check_cleanup
78cve_check_cleanup[eventmask] = "bb.cooker.CookerExit"
79
80python cve_check_write_rootfs_manifest () {
81 """
82 Create CVE manifest when building an image
83 """
84
85 import shutil
86
Brad Bishopd7bf8c12018-02-25 22:55:05 -050087 if d.getVar("CVE_CHECK_COPY_FILES") == "1":
88 deploy_file = os.path.join(d.getVar("CVE_CHECK_DIR"), d.getVar("PN"))
89 if os.path.exists(deploy_file):
90 bb.utils.remove(deploy_file)
91
Brad Bishop6e60e8b2018-02-01 10:27:11 -050092 if os.path.exists(d.getVar("CVE_CHECK_TMP_FILE")):
Patrick Williamsc0f7c042017-02-23 20:41:17 -060093 bb.note("Writing rootfs CVE manifest")
Brad Bishop6e60e8b2018-02-01 10:27:11 -050094 deploy_dir = d.getVar("DEPLOY_DIR_IMAGE")
95 link_name = d.getVar("IMAGE_LINK_NAME")
96 manifest_name = d.getVar("CVE_CHECK_MANIFEST")
97 cve_tmp_file = d.getVar("CVE_CHECK_TMP_FILE")
Patrick Williamsc0f7c042017-02-23 20:41:17 -060098
99 shutil.copyfile(cve_tmp_file, manifest_name)
100
101 if manifest_name and os.path.exists(manifest_name):
102 manifest_link = os.path.join(deploy_dir, "%s.cve" % link_name)
103 # If we already have another manifest, update symlinks
104 if os.path.exists(os.path.realpath(manifest_link)):
105 os.remove(manifest_link)
106 os.symlink(os.path.basename(manifest_name), manifest_link)
107 bb.plain("Image CVE report stored in: %s" % manifest_name)
108}
109
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500110ROOTFS_POSTPROCESS_COMMAND_prepend = "${@'cve_check_write_rootfs_manifest; ' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500111do_rootfs[recrdeptask] += "${@'do_cve_check' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600112
113def get_patches_cves(d):
114 """
115 Get patches that solve CVEs using the "CVE: " tag.
116 """
117
118 import re
119
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500120 pn = d.getVar("PN")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600121 cve_match = re.compile("CVE:( CVE\-\d{4}\-\d+)+")
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500122
123 # Matches last CVE-1234-211432 in the file name, also if written
124 # with small letters. Not supporting multiple CVE id's in a single
125 # file name.
126 cve_file_name_match = re.compile(".*([Cc][Vv][Ee]\-\d{4}\-\d+)")
127
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600128 patched_cves = set()
129 bb.debug(2, "Looking for patches that solves CVEs for %s" % pn)
130 for url in src_patches(d):
131 patch_file = bb.fetch.decodeurl(url)[2]
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500132
133 # Check patch file name for CVE ID
134 fname_match = cve_file_name_match.search(patch_file)
135 if fname_match:
136 cve = fname_match.group(1).upper()
137 patched_cves.add(cve)
138 bb.debug(2, "Found CVE %s from patch file name %s" % (cve, patch_file))
139
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600140 with open(patch_file, "r", encoding="utf-8") as f:
141 try:
142 patch_text = f.read()
143 except UnicodeDecodeError:
144 bb.debug(1, "Failed to read patch %s using UTF-8 encoding"
145 " trying with iso8859-1" % patch_file)
146 f.close()
147 with open(patch_file, "r", encoding="iso8859-1") as f:
148 patch_text = f.read()
149
Brad Bishopbba38f32018-08-23 16:11:46 +0800150 # Search for one or more "CVE: " lines
151 text_match = False
152 for match in cve_match.finditer(patch_text):
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600153 # Get only the CVEs without the "CVE: " tag
154 cves = patch_text[match.start()+5:match.end()]
155 for cve in cves.split():
156 bb.debug(2, "Patch %s solves %s" % (patch_file, cve))
157 patched_cves.add(cve)
Brad Bishopbba38f32018-08-23 16:11:46 +0800158 text_match = True
159
160 if not fname_match and not text_match:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600161 bb.debug(2, "Patch %s doesn't solve CVEs" % patch_file)
162
163 return patched_cves
164
165def check_cves(d, patched_cves):
166 """
Brad Bishopf3fd2882019-06-21 08:06:37 -0400167 Connect to the NVD database and find unpatched cves.
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600168 """
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600169 import ast, csv, tempfile, subprocess, io
Brad Bishopf3fd2882019-06-21 08:06:37 -0400170 from distutils.version import LooseVersion
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600171
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600172 cves_unpatched = []
Brad Bishopf3fd2882019-06-21 08:06:37 -0400173 # CVE_PRODUCT can contain more than one product (eg. curl/libcurl)
Brad Bishop96ff1982019-08-19 13:50:42 -0400174 products = d.getVar("CVE_PRODUCT").split()
Brad Bishop316dfdd2018-06-25 12:45:53 -0400175 # If this has been unset then we're not scanning for CVEs here (for example, image recipes)
Brad Bishop96ff1982019-08-19 13:50:42 -0400176 if not products:
Brad Bishop316dfdd2018-06-25 12:45:53 -0400177 return ([], [])
178 pv = d.getVar("CVE_VERSION").split("+git")[0]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600179
180 # If the recipe has been whitlisted we return empty lists
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500181 if d.getVar("PN") in d.getVar("CVE_CHECK_PN_WHITELIST").split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600182 bb.note("Recipe has been whitelisted, skipping check")
183 return ([], [])
184
Brad Bishop96ff1982019-08-19 13:50:42 -0400185 old_cve_whitelist = d.getVar("CVE_CHECK_CVE_WHITELIST")
186 if old_cve_whitelist:
187 bb.warn("CVE_CHECK_CVE_WHITELIST is deprecated, please use CVE_CHECK_WHITELIST.")
188 cve_whitelist = d.getVar("CVE_CHECK_WHITELIST").split()
189
Brad Bishopf3fd2882019-06-21 08:06:37 -0400190 import sqlite3
191 db_file = d.getVar("CVE_CHECK_DB_FILE")
192 conn = sqlite3.connect(db_file)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600193
Brad Bishop96ff1982019-08-19 13:50:42 -0400194 for product in products:
195 c = conn.cursor()
196 if ":" in product:
197 vendor, product = product.split(":", 1)
198 c.execute("SELECT * FROM PRODUCTS WHERE PRODUCT IS ? AND VENDOR IS ?", (product, vendor))
199 else:
200 c.execute("SELECT * FROM PRODUCTS WHERE PRODUCT IS ?", (product,))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600201
Brad Bishop96ff1982019-08-19 13:50:42 -0400202 for row in c:
203 cve = row[0]
204 version_start = row[3]
205 operator_start = row[4]
206 version_end = row[5]
207 operator_end = row[6]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600208
Brad Bishop96ff1982019-08-19 13:50:42 -0400209 if cve in cve_whitelist:
210 bb.note("%s-%s has been whitelisted for %s" % (product, pv, cve))
Brad Bishopf3fd2882019-06-21 08:06:37 -0400211 elif cve in patched_cves:
212 bb.note("%s has been patched" % (cve))
Brad Bishopf3fd2882019-06-21 08:06:37 -0400213 else:
Brad Bishop96ff1982019-08-19 13:50:42 -0400214 to_append = False
215 if (operator_start == '=' and pv == version_start):
216 cves_unpatched.append(cve)
217 else:
218 if operator_start:
219 try:
220 to_append_start = (operator_start == '>=' and LooseVersion(pv) >= LooseVersion(version_start))
221 to_append_start |= (operator_start == '>' and LooseVersion(pv) > LooseVersion(version_start))
222 except:
223 bb.note("%s: Failed to compare %s %s %s for %s" %
224 (product, pv, operator_start, version_start, cve))
225 to_append_start = False
226 else:
227 to_append_start = False
228
229 if operator_end:
230 try:
231 to_append_end = (operator_end == '<=' and LooseVersion(pv) <= LooseVersion(version_end))
232 to_append_end |= (operator_end == '<' and LooseVersion(pv) < LooseVersion(version_end))
233 except:
234 bb.note("%s: Failed to compare %s %s %s for %s" %
235 (product, pv, operator_end, version_end, cve))
236 to_append_end = False
237 else:
238 to_append_end = False
239
240 if operator_start and operator_end:
241 to_append = to_append_start and to_append_end
242 else:
243 to_append = to_append_start or to_append_end
244
245 if to_append:
246 cves_unpatched.append(cve)
247 bb.debug(2, "%s-%s is not patched for %s" % (product, pv, cve))
Brad Bishopf3fd2882019-06-21 08:06:37 -0400248 conn.close()
249
250 return (list(patched_cves), cves_unpatched)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600251
252def get_cve_info(d, cves):
253 """
Brad Bishop96ff1982019-08-19 13:50:42 -0400254 Get CVE information from the database.
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600255
256 Unfortunately the only way to get CVE info is set the output to
257 html (hard to parse) or query directly the database.
258 """
259
260 try:
261 import sqlite3
262 except ImportError:
263 from pysqlite2 import dbapi2 as sqlite3
264
265 cve_data = {}
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500266 db_file = d.getVar("CVE_CHECK_DB_FILE")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600267 placeholder = ",".join("?" * len(cves))
268 query = "SELECT * FROM NVD WHERE id IN (%s)" % placeholder
269 conn = sqlite3.connect(db_file)
270 cur = conn.cursor()
271 for row in cur.execute(query, tuple(cves)):
272 cve_data[row[0]] = {}
273 cve_data[row[0]]["summary"] = row[1]
Brad Bishopf3fd2882019-06-21 08:06:37 -0400274 cve_data[row[0]]["scorev2"] = row[2]
275 cve_data[row[0]]["scorev3"] = row[3]
276 cve_data[row[0]]["modified"] = row[4]
277 cve_data[row[0]]["vector"] = row[5]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600278 conn.close()
279
280 return cve_data
281
282def cve_write_data(d, patched, unpatched, cve_data):
283 """
284 Write CVE information in WORKDIR; and to CVE_CHECK_DIR, and
285 CVE manifest if enabled.
286 """
287
Brad Bishop316dfdd2018-06-25 12:45:53 -0400288 cve_file = d.getVar("CVE_CHECK_LOG")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600289 nvd_link = "https://web.nvd.nist.gov/view/vuln/detail?vulnId="
290 write_string = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500291 unpatched_cves = []
Brad Bishop316dfdd2018-06-25 12:45:53 -0400292 bb.utils.mkdirhier(os.path.dirname(cve_file))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600293
294 for cve in sorted(cve_data):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500295 write_string += "PACKAGE NAME: %s\n" % d.getVar("PN")
296 write_string += "PACKAGE VERSION: %s\n" % d.getVar("PV")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600297 write_string += "CVE: %s\n" % cve
298 if cve in patched:
299 write_string += "CVE STATUS: Patched\n"
300 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500301 unpatched_cves.append(cve)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600302 write_string += "CVE STATUS: Unpatched\n"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600303 write_string += "CVE SUMMARY: %s\n" % cve_data[cve]["summary"]
Brad Bishopf3fd2882019-06-21 08:06:37 -0400304 write_string += "CVSS v2 BASE SCORE: %s\n" % cve_data[cve]["scorev2"]
305 write_string += "CVSS v3 BASE SCORE: %s\n" % cve_data[cve]["scorev3"]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600306 write_string += "VECTOR: %s\n" % cve_data[cve]["vector"]
307 write_string += "MORE INFORMATION: %s%s\n\n" % (nvd_link, cve)
308
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500309 if unpatched_cves:
310 bb.warn("Found unpatched CVE (%s), for more information check %s" % (" ".join(unpatched_cves),cve_file))
311
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600312 with open(cve_file, "w") as f:
313 bb.note("Writing file %s with CVE information" % cve_file)
314 f.write(write_string)
315
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500316 if d.getVar("CVE_CHECK_COPY_FILES") == "1":
317 cve_dir = d.getVar("CVE_CHECK_DIR")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600318 bb.utils.mkdirhier(cve_dir)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500319 deploy_file = os.path.join(cve_dir, d.getVar("PN"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600320 with open(deploy_file, "w") as f:
321 f.write(write_string)
322
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500323 if d.getVar("CVE_CHECK_CREATE_MANIFEST") == "1":
324 with open(d.getVar("CVE_CHECK_TMP_FILE"), "a") as f:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600325 f.write("%s" % write_string)