blob: 68105d9b84f916c8d86ad7aa7301b19aa2652e56 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001# Some of the vars for vm and live image are conflicted, this function
2# is used for fixing the problem.
3def set_live_vm_vars(d, suffix):
4 vars = ['GRUB_CFG', 'SYSLINUX_CFG', 'ROOT', 'LABELS', 'INITRD']
5 for var in vars:
6 var_with_suffix = var + '_' + suffix
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007 if d.getVar(var):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05008 bb.warn('Found potential conflicted var %s, please use %s rather than %s' % \
9 (var, var_with_suffix, var))
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 elif d.getVar(var_with_suffix):
11 d.setVar(var, d.getVar(var_with_suffix))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050012
13
14EFI = "${@bb.utils.contains("MACHINE_FEATURES", "efi", "1", "0", d)}"
15EFI_PROVIDER ?= "grub-efi"
16EFI_CLASS = "${@bb.utils.contains("MACHINE_FEATURES", "efi", "${EFI_PROVIDER}", "", d)}"
17
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018MKDOSFS_EXTRAOPTS ??= "-S 512"
19
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050020# Include legacy boot if MACHINE_FEATURES includes "pcbios" or if it does not
21# contain "efi". This way legacy is supported by default if neither is
22# specified, maintaining the original behavior.
23def pcbios(d):
24 pcbios = bb.utils.contains("MACHINE_FEATURES", "pcbios", "1", "0", d)
25 if pcbios == "0":
26 pcbios = bb.utils.contains("MACHINE_FEATURES", "efi", "0", "1", d)
27 return pcbios
28
29PCBIOS = "${@pcbios(d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030PCBIOS_CLASS = "${@['','syslinux'][d.getVar('PCBIOS') == '1']}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050031
32inherit ${EFI_CLASS}
33inherit ${PCBIOS_CLASS}
34
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050035populate_kernel() {
36 dest=$1
37 install -d $dest
38
39 # Install bzImage, initrd, and rootfs.img in DEST for all loaders to use.
Brad Bishop316dfdd2018-06-25 12:45:53 -040040 bbnote "Trying to install ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE} as $dest/${KERNEL_IMAGETYPE}"
41 if [ -e ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE} ]; then
42 install -m 0644 ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE} $dest/${KERNEL_IMAGETYPE}
Patrick Williamsc0f7c042017-02-23 20:41:17 -060043 else
Brad Bishop316dfdd2018-06-25 12:45:53 -040044 bbwarn "${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE} doesn't exist"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050045 fi
46
47 # initrd is made of concatenation of multiple filesystem images
48 if [ -n "${INITRD}" ]; then
49 rm -f $dest/initrd
50 for fs in ${INITRD}
51 do
52 if [ -s "$fs" ]; then
53 cat $fs >> $dest/initrd
54 else
55 bbfatal "$fs is invalid. initrd image creation failed."
56 fi
57 done
58 chmod 0644 $dest/initrd
59 fi
60}
61