blob: 5d6f200a7361fa43c72859e08732f5653b127f10 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
2SUMMARY = "EFI Boot Manager"
3HOMEPAGE = "https://github.com/rhboot/efibootmgr"
4SECTION = "base"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9DEPENDS = "efivar popt"
10
11COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
12
13SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
14 file://0001-remove-extra-decl.patch \
Brad Bishop96ff1982019-08-19 13:50:42 -040015 file://97668ae0bce776a36ea2001dea63d376be8274ac.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040016 "
17SRCREV = "e067160ecef8208e1944002e5d50b275733211fb"
18
19S = "${WORKDIR}/git"
20
21inherit pkgconfig
22
23# The directory under the ESP that the default bootloader is found in. When
24# wic uses a subdirectory, this should use the same one too.
25EFIDIR ?= "/"
26
27EXTRA_OEMAKE += "'EFIDIR=${EFIDIR}'"
28
29CFLAGS += " -Wno-error"
30
31do_install () {
32 oe_runmake install DESTDIR="${D}"
33}
34
35CLEANBROKEN = "1"