blob: 068ae762d4efb9df702c61050d61fc48d66eb6a4 [file] [log] [blame]
Brad Bishopf3fd2882019-06-21 08:06:37 -04001SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)"
2DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration."
3LICENSE = "BSD-2-Clause"
Brad Bishop96ff1982019-08-19 13:50:42 -04004LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=42dd9555eb177f35150cf9aa240b61e5"
Brad Bishopf3fd2882019-06-21 08:06:37 -04005DEPENDS += "dtc-native"
6
7require opensbi-payloads.inc
8
9inherit autotools-brokensep
10
Brad Bishop96ff1982019-08-19 13:50:42 -040011SRCREV = "ce228ee0919deb9957192d723eecc8aaae2697c6"
Brad Bishopf3fd2882019-06-21 08:06:37 -040012SRC_URI = "git://github.com/riscv/opensbi.git \
13 file://0001-Makefile-Don-t-specify-mabi-or-march.patch \
Brad Bishopf3fd2882019-06-21 08:06:37 -040014 "
15
16S = "${WORKDIR}/git"
17
18SRC_URI[md5sum] = "621f38d8205ef5fb185e4055025e73df"
19SRC_URI[sha256sum] = "07f18b73abf3b85aabe5bead19a923716c100d30eb58033459f39c3a224be300"
20
21EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D}"
22# If RISCV_SBI_PAYLOAD is set then include it as a payload
23EXTRA_OEMAKE_append = " ${@riscv_get_extra_oemake_image(d)} ${@riscv_get_extra_oemake_fdt(d)}"
24
25# Required if specifying a custom payload
26do_compile[depends] += "${@riscv_get_do_compile_depends(d)}"
27
28do_install_append() {
29 # In the future these might be required as a dependency for other packages.
30 # At the moment just delete them to avoid warnings
31 rm -r ${D}/include
32 rm -r ${D}/platform/${RISCV_SBI_PLAT}/lib
33 rm -r ${D}/platform/${RISCV_SBI_PLAT}/firmware/payloads
Brad Bishop96ff1982019-08-19 13:50:42 -040034 rm -r ${D}/lib
Brad Bishopf3fd2882019-06-21 08:06:37 -040035}
36
37do_deploy () {
38 install -d ${DEPLOY_DIR_IMAGE}
39 install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOY_DIR_IMAGE}/
40 install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOY_DIR_IMAGE}/
Brad Bishop96ff1982019-08-19 13:50:42 -040041 install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOY_DIR_IMAGE}/
Brad Bishopf3fd2882019-06-21 08:06:37 -040042}
43
44addtask deploy after do_install
45
46FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
47FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.*"
Brad Bishop96ff1982019-08-19 13:50:42 -040048FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
49
Brad Bishopf3fd2882019-06-21 08:06:37 -040050
51COMPATIBLE_HOST = "(riscv64|riscv32).*"
52INHIBIT_PACKAGE_STRIP = "1"